Location tracking stopped working after 1.2.0 update

After updating the app to 1.2.0 to get push notification support, location tracking is no longer working.
The location and battery level hasn’t updated since last night at around 10 PM (UTC).
I have tried restarting both the app and HA, but the only thing that has changed (I believe this was after restarting HA) is the timestamp (last_changed) but the location and battery level are still those from last night.
I have not yet updated HA from 0.102.3 to 0.103.0, is there something in the app update which requires HA to be updated for tracking to work or is this some other issue?

Edit: I’ve even tried the following steps:

  • Logged out of the app
  • Deleted the device from Integrations
  • Restarted Home Assistant (at which point the device tracker disappeared)
  • Logged back into the app

But it is still stuck with the old data.

1 Like

You should open the app settings and enable the tracking again.


Thanks, that worked, I hadn’t thought to check there.