Locked Out of Zwavejs2mqtt After Enabling HTTPS

Following on from here (thanks @RickKramer for initial assistance).

I have HA installed in a Docker container on a Synology NAS. I have had Zwavejs2mqtt working successfully alongside it in another container. The setup for Zwavejs2mqtt is via docker-compose as follows.

The issue I have is that I enabled the https option from within the Zwavejs2mqtt UI and have now locked myself out of it. When I access https://{ip}:8091 I get: Your connection is not private

I believe I need to manually revert the configuration option in question, but I’m stuck in trying to do so. I understand it’s a folder called zwave-config given the docker-compose below. Looking under /volume1/docker/zwavejs2mqtt I see the zwave-config folder I believe I created initially, but it is empty. I can’t see a similarly named file anywhere else (possibly at the root). So now I’m stuck.

My questions are:

  1. Where is my config (it’s clearly saved somewhere as I’ve re-built the Zwavejs2mqtt container and I’m still stuck out), and
  2. When I find it, how to I revert the offending option
version: '3.7'
    container_name: zwavejs2mqtt
    image: zwavejs/zwavejs2mqtt:latest
    restart: always
    tty: true
    stop_signal: SIGINT
      - SESSION_SECRET=mysupersecretkey
      - ZWAVEJS_EXTERNAL_CONFIG=/usr/src/app/store/.config-db
      - TZ=Australia/Perth
      - zwave
      # Do not use /dev/ttyUSBX serial devices, as those mappings can change over time.
      # Instead, use the /dev/serial/by-id/X serial device for your Z-Wave stick.
      - '/dev/ttyUSB0:/dev/zwave'
      - zwave-config:/usr/src/app/store
      - '8091:8091' # port for web interface
      - '3000:3000' # port for Z-Wave JS websocket server
    name: zwave-config

As it seems you’re using native docker volumes I’m not sure where they go on a Synology. Maybe this site is correct:

Perhaps you can use the Container’s shell to edit the configuration file using an available editor?

I think, at least this part, should be changed to
- /volume1/docker/zwavejs2mqtt:/usr/src/app/store

And question - why did you even go for SSL certificate? You could have used reverse proxy from within Synology, get SSL access and avoid all possible current and future issues.

Thanks very much Rick. This is correct. My steps to resolve:

  • ssh to Synology
  • sudo -i
  • /volume1/@docker/volumes/zwave-config/_data
  • vim settings.json
  • reset https from true to false, save and exit
  • restart zwavejs2mqtt container

Thanks for your comment. I have located my config in a “native volume” (something I knew nothing about until now) so may consider moving it to that location as it would be consistent with my other locations. I’ve followed a lot of your videos on my setup and only erred here because I used a docker-compose instead. Thanks for all your great work oin youtube.

To answer your question, I didn’t want to use SSL. It was a late night mis-click that’s cost me hours (not the first such one) because I had noticed when viewing Home Assistant remotely my i-frames to other ports don’t work. I don’t think this would have ever solved that issue. Embarassingly I can’t even exactly remember how I have setup remote access to Home Assistant - do you have a video on the reverse proxy as that was something I came across when trying to set it all up but I’m not sure I ended up using for one reason or another.

Are you running on Dsm 7.x or Dsm 6.x?