Logbook dashboard no longer working after update to 2022.6.0

Anyone else having this issue? After upgrading to 2022.6.0, the ‘Logbook’ page accessible from the left panel shows no results at all.

I can add a logbook card to a dashboard and that seems to work fine, but the general logbook that was accessible there showing event logs is no longer showing anything.

I’m running core-2022.6.0 on Docker

I think it’s an issue that’s reported by more people in 2022.6: Gaining new insights!

I notice that when you select an entity, that it does show logs for that entity, but when not selecting an entity, it’s not exactly clear what happens. It shows some new items once log is open when the log is written, but when you leave and come back, the log item is gone…

I cannot exactly figure out what is actually happening. No logic from the user perspective.

Currently running
Version: core-2022.6.0
Installation: Home Assistant OS|

If you click on the “left log-panel-view” then you notice the “time/calender” And also the start/end time, this have change(i think) only showing an hour back or so ( keeps changing during the day, i guess it’s to avoid to extensive entrys , if someone have many )
You can click the “Calender” choose either today ( or time , i.e 12pm> ), yesterday, this week,last week, And of-cause as usual, manual choose time-span ( thou it seems like you can’t “cross” over a month anymore )

I just noticed the date fields default to today, and the end field defaults to about 2 hours in the future.

Also just confirmed that selecting an entity will show that entities logs, but not selecting anything (which should show the global logbook) does nothing. Hope this gets fixed soon.

1 Like

maybe you just dont have any, from the "start time > until now, try click on “Today” or set the time (in the bottom ) to 6 hours ago

I have indeed same issues , nothing to see anymore … Sometimes it f you wait a while, some events are popping up very slowly

GO to your logbook , Click on the calender, Click on Today … if you still have problems seeing events, then you could have a problem

It’s always empty :slight_smile:

:frowning: … ok, sorry to hear, thou im glad for the improvements i see, thou i would have wished that it kept the settings :slight_smile:

Solved in 2022.6.1

This is still not working right for me. I still get the empty page saying ‘No logbook events found.’

Just to confirm, I am at my_homeassistant_ip:PORT/logbook

I have just gone to 2022.6.1 and I see entries in my logbook but they are not filtered according to my yaml as they were before. Anyone else seeing that behaviour? So I am seeing logbook entiries for what looks like every entity but my yaml is:

      # - automation.front_door_alert
      # - automation.front_door_bell
      - person.gavin
      - person.merlijn
      - person.abigail
      - climate.air_conditioner
      - sensor.speedtest_download
      - sensor.speedtest_upload
      - sensor.speedtest_ping
      - sensor.abigail_temp_sensor_temperature
      - sensor.0x00158d0001b95355_temperature # Grace Room Temp
      - sensor.0x00158d0001fa38b3_temperature # Study Room Temp
      - sensor.rumpus_aircon
      - switch.abigail_light_fan_switch_button_light
      - switch.hannah_light_fan_switch_button_light
      - switch.grace_light_fan_switch_button_light
      - alarm_control_panel.alarm_panel
      - automation
      - script

EDIT: I think this is similarly reported here: 2022.6: Gaining new insights! - #230 by Ildar_Gabdullin

My issue was about “specify an entity to Logbook card which is not supposed to be displayed in Logbook”.
But in the “big” Loogbok (an a separate page) these “wrong” entities just cannot be selected - hence cannot cause the glitch I described.

OK thanks. Yeah I am looking at the main logbook page and it is longer filtered according to my configuration.yaml settings. I will raise an issue as it isn’t fixed in 2022.6.2 which I just upgrade to and I don’t think I can see any similar issue other than yours.