Logger Raw Only

dump: all
level: VERBOSE

By clicking the LOGS button in esphome

How do I view just raw data and prevent esphome from trying to find a protocol to use. Because it is guessing wrong. I need just the millisecond data from the pulse widths.

What component are you talking about?
Infrared receiver?
Help us to help you.

Both or either ir or rf … Remote Receiver stuff
I have a need to see the raw pulse width data from rf and ir. I’ve been using a oscope to look at it now and then manually entering the data for raw transmission… Lots of work.
For instance a Honeywell fan ir remote recieves a guess of two different protocols nec and samsung. Both are wrong. But since it is guessing the logger skips showing the raw pulse width info.

  name: esphome

  board: d1_mini

# Enable logging
#  level: VERY_VERBOSE

# Enable Home Assistant API

  password: "3d240ca87586539769f60tyter"

  ssid: "ssid"
  password: "password"

  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "Fallback Hotspot"
    password: ergsgw54g4w


remote_receiver:    #working with A2ABTAE-d2
  - id: RF_RCV
      number: D4
    tolerance: 60%
    filter: 350us
    idle: 4ms
    buffer_size: 2kb   
    dump: rc_switch   #all      all is lots but good
    - raw
  - raw

Worked perfect :smiley:

Now I am able to see Only the pulse width data from the LOGS button receiving through remote_receiver
This is sometimes needed if your remote is not using one of the protocols known to esphome for now.

The Faking an IR remote post is awesome.

The list of dump: options are here.

raw: Print all remote codes in their raw form. Useful for using arbitrary protocols.

Thank you Jpsy

1 Like