Logger showing warnings when error set as default

According to the logger page, if I set default: error I shouldn’t see anything below that level such as warnings. I have set this and restarted HA, but the warnings are still showing on the warning screen.

  default: error

This is correct yes?

You can have logger: settings in multiple places - most common place is your configuration.yaml file. I use a different file to manage my logger settings, and I refer to that file in my configuration.yaml file.

Here is my logging file for your reference. You may have to restart HA after making changes, and note that it will not delete existing messages from your log file.

I assume you mean the System Log with the “warning screen”?
There’s an open issue that it ignores the logger settings.

Ah, I thought this might be the case. OK I’ll keep an eye on that issue to see if it gets resolved soon