Login failed for Miele@home Integration

Hi Folks,

I’m struggling with configuring the Miele@home Integration. I followed the instructions on https://github.com/minzel/home-assistant-miele, which works very well.

After the reboot I had a notification which prompts me to link the Miele account.

I got forwardet to the following Url:
(senitiv data is removed)

When I enter my credentials of my Miele-Account the Authentication always get failed:

I tested the Client ID and Client Secret also in my ioBroker Instance and it worked perfectly, so there is nothing wrong with it. I’ve stored Client ID, Client Secret and my login in a Passwordsafe and use always Copy’n’Paste to insert these data anywhere, so typos are excluded.

Miele section in /config/configuration.yaml:

    client_id: 1b<...>b3
    client_secret: A<...>S
    lang: de

Does anyone have any idea what’s goning wrong here?

Thanks in advance!



Hello, Have you by chance found a solution? I am in the same problem

1 Like

Same here… My pass is certainly correct as I can log-in to the Miele store.

Same problem here, did anyone happen to find a solution?

Guessing this is no longer working?

I’ve been using the HACS Miele integration and it’s been working fine for me.

The only issue I’ve had recently has been with Miele App not seeing the machine.
As a result HA can’t see it either as it’s an IOT Miele account issue.

Once I re-add it to my app/account it automatically shows up again in HA.

Me three only get autentication failure

I am having the same problem.

Did anyone find a solution?

Maybe it takes some time for Miele to allow you on to to use their API?

Same here :frowning:

I ran into similar problems.
I deleted the integration and and also removed the credentials (client ID/ Token stored in home assistant.)
After that the installation installation worked and I was able to provide the credentials.

I know this is an old thread but I just went through this on the new integration so I thought I would share in case it helps the next person googling. I had the same issue with my linking failed even though my login details were correct. The problem ended up being my Miele@home account was configured for the wrong country, (Canada rather than Australia). When I set my country to Canada in the login details it Authenticated successfully :slight_smile: