Login Loop with correct creds


I am having some issue at login and cant seem to find anyone having the same issue. after entering my log in details into home assistant I am sent to a browser page that reads:
“You’re about to give http://homeassistant.local:8123/ access to your Home Assistant instance
Logging in with Home Assistant Local.”

Nothing else loads other than a “Start Over” Button.

Why is this happening? I am testing HA to see if its something I am interested in. But so far i have had nothing but issues.

For what its worth, my HA instance is running on a Proxmox KVM with 2 cores, 4Gb of ram, and 32Gb storage. More can be allocated as/if needed.

Did you ever solve this?

This is currently a problem on iOS 16.1.1 for me on the iPhone 14 using the most up-to-date app version 2022.10.1. I then get a notification in my home assistant of invalid login even though I know it is correct. I am currently able to log in with the Android app on other devices so I know the username and password are correct, but something appears to be wrong logging into Home Assistant Core 2022.11.5.

This also happens with Chrome on iOS. I can log into the app from Firefox on Linux, the App on Android, and Firefox or Chrome on Android no problem. It appears that all attempts to log in from iOS are triggering a “Login Attempt Failed” in the logs.

I wonder if the password hiding field is to blame? My password has an “@”, “$”, and “*” so maybe something in the text sanitizing in the password field is getting scrambled? Or it’s a safari thing, aren’t all these using a safari based web rendering engine, which is a commonality?

This must have been a change because this same account and same password worked on a previous iPhone, this came up when my wife got a new phone and tried to transition the account to the new device.

Additional debug information, we changed the password to one with no special characters and are getting the same results. We can login fine on Android, Linux, Chrome OS, Chrome browser, Firefox browser, but not the app or web on iOS.

Try clearing the refresh tokens for android.home-assistant.io from the user’s /profile page.

I just hit this after spending hours fighting my phone and watch, registered just to answer with the hope that it’ll save someone time.

1 Like