Logitech Harmony Discovery

Hi Guys,

New to home-assistant and finding a couple of things confusing. I appear to have discovery working, it found a couple of devices on my network and I see them in devices and integration after configuration.

The Harmony Hub, however, appears to be discovered as I have a harmony_devicename.conf file, but I do not see it in devices, integration or developer tools > states.

I am a smartthings users and moving over to home-assistant, I also have smartthings connected to home-assistant during this move, so I’m unsure if there is some form of conflict.


Start here: https://www.home-assistant.io/integrations/harmony/

it’ll have the name entity_id:


Thanks, if I filter on “Current entities” for “remote” I don’t get any results.

Try hard coding it instead of relying on discovery.

I would also suggest turning off auto discovery of harmony. I was having problems with hubs disappearing and reappearing until I turned off auto discovery for harmony and hard coded them.

Thanks, It’s working via static, although it didn’t work with this config at some point. It feels flaky.

I cannot set the IP static on the hub and I don’t like to do static maps via DHCP. :confused:

Why not that’s the best way

I’m new to HA as well and this one threw me for a few minutes. It only gets created as an entity, not a device. Go to Configuration->Entities and look for an entity_id starting with remote.something.
Sorry, hadn’t refreshed my browser.

If you want to assign a specific IP to a hub, that’s the only way. There’s no mechanism in the hub setup to assign a static IP. DHCP address reservation is the right way to do it anyway.

I’ve been playing around with the discovery peace and done some pcaps. It is discovering it and I see traffic on port TCP/8088, however when comparing it with the static entry in configuration.yaml, I see a string of resets coming from the Harmony Hub. So something is broken in its discovery peace!

Where would you report any bugs like this?