Logitech Harmony removes local API


#203

I just updated hassio to the lates version 0.85.1. Do I also update my harmony hub to the lates firmware or what do I need to do?

Thank you!


#204

nope, not needed, websockets works with every firmware of your hub


#205

Thank you!

But I think it will force update it, unless I block some sites.


#206

you dont need to block it anymore, they launched an development relase a while ago, version 210
that one still using the old API, but you need to run then harmony as custom component
grab if from 84.3 or older if you want to use the old api

but for me websockets is also working good here, using 85.1


#207

I have let my harmony update to the latest version.
I haven’t changes anything in my configuration other that that i had to ad the hub to the config.yaml with his ip address to be found.

I had it setup with an input select.

It his moment i see the harmony, and it reacts to an on and of signal, but my input select does not update and i can’t use it to switch activities.

What do i need to do if i want to make use of the websocket functionality, i haven’t set up any websocket things.

I can’t seem to find useful information on this.


#208

I found 0.88 on the Docker HUB and updated, and now everything works again - like a charm! I’m happy :heart_eyes:


#209

Hi,

for the ones using harmony.py as a custom component, make sure you rename it now to remote.py and the folder remote, rename that to harmony
t-its a breaking change in 0.88 :slight_smile:
if you have this line in your log, you are good :slight_smile:

(MainThread) [homeassistant.loader] You are using a custom component for harmony.remote which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.


#210

I love you guys for posting this, thanks


#211

Guys I wanna use the custom component so I’ve put it in the right folder but how do I tell HA to use custom not the one already installed?
Cheers


#212

custom overrides so it should just happen.


#213

I thought the same but it’s not in the log at all…


#214

You are aware there are new rules for custom components in 0.89?


#215

Yeah I have remote.py in harmony folder in custom_components… That’s the new right way yeah?


#216

I think so


#217

Can anyone using the custom component please explain how you did it? I’m on hassio on Ubuntu.
I have put the remote.py in harmony folder in custom_components but it’s still loading the main component…
Cheers


#218

Check your logs. There were other pieces of the update that broke some things as well. I had to change one important statement on a custom component for a pioneer vsx 1022.


#219

Nothing in the logs at all, This is how I know it’s not loading the custom one.


#220

Do you have at least a blank
init.py
file in the same folder? The init has to have two underscores before and after it.


#221

That did it… Thanks very much


The Great Migration
#222

hi Guys, just wanted to let you know also in this blog/thread that @ehendrix is modifying improving the harmony component

its a PR that needs to be tested !

see his reply here

PR is here : https://github.com/home-assistant/home-assistant/pull/22046

with the new component, the harmony component will now check if XMPP is enabled on the HUB
if yes, then its using the XMPP connection, if not enabled, it falls back to websocket

and also some new stuff

  1. Ability to add a delay for a send command (simulating pressing the button on a remove for x seconds)
  2. Added service change_channel
  3. When sending commands, the device name can be used (instead of device ID)