Logitech Media Server integration problems

I have for the past week enjoyed my new LMS setup on a Pi2 connected to by a Zero W with PiCorePlayer. Naturally I want to integrated that into HA and had actually expected LMS to be auto detected when I upgraded HA to 21.3.3 the other day but it didn’t. Instead I tried to add it myself from the integration page and it correctly find the IP and port but it gives me a “User input malformed” when I try to submit. I thought maybe it was because it required a Username/Password so I enabled that on LMS but it still gives me the same error.
I also tried manually entering it in my media_players yaml but it only show up as a disabled (grayed) multi-room controller.
I am therefore hoping that some of the smart people in the community could point me in the right direction to get this integration working.

Thank you in advance.

If you enter the IP LMS and port 9000 into the web browser, the LMS server will open?

Yes LMS is working perfectly outside of HA and I can manage the interface and rescan fine from the browser.

It’s been a long time since I’ve set it up, so I don’t remember well. During the integration in HA, I entered the IP, port and I don’t know if the login details for Logitech. It works well. I recently added piCorePlayer (Rpi zero w) and it found it automatically.
I would try to remove the LMS integration, restart the HA and re-add the LMS, fill in the required data and reserve an IP for the LMS in the router.

I got it working.
I always use static IP’s for my boxes and put them on a separate subnet so it couldn’t be that. However it turned out I had a rouge entry in my configuration file that once it was removed everything started working.

It seems I am having the same or a similar issue here. Maybe someone can help.
Using a browser I can connect to my LMS using the IP adress on port 9000. I have a Pi2 running on PiCorePlayer as LMS and also as player (on the same Pi).

However, when I try to install the Squeezebox integration in HA I am getting the error: User input malformed. I even tried setting up a MySqueezebox account and using this as user/pw input, no success.

@hassioNewb: In what configuration file did you find a rogue entry? Could explain this to me?
And how can I set up a password for LMS, if that is neccessary?

Thanks a bunch in advance!

I had created a media_players.yaml file earlier that had a number of players listed including a multi_room controller. I had not given this a host name so I suspect it blocked LMS from getting auto configured. Once I deleted the entry I had no problem with LMS.
Check you have not manually included LMS in your configuration and then try restarting HA and see if you can add it then via the integration page.

Thank you for letting me know the details!
No luck so far. I did not experiment with yaml files yet and hence have no media_players.yaml in my configuration. Restarting/rebooting both Pis did not help either.
Maybe I will give it a shot and start with a fresh HA install on a second micro SD card.
I have really just started looking into home automation, so no big loss here :wink:

But I am of course open for other suggestions, too. I would even try a manual configuration if possible. However, I am not an IT expert but rather a user with basic programming skills and would need a hint where to start.

Thanks again

I am experiencing the same issues with installing the Logitech Squeezebox Integration.

I have no password protection to access the server but no matter what I input when setting up the integration - blank fields or not, I get the “User Input Malformed” message.

I think this issue has been around since Home Assistant 2021.3, and the developer has fixed it with a PR, which has been merged. I guess it will come with the next official release of Home Assistant.

There are ways to install fixes to core components ahead of their official release if you can’t wait. You basically install the core component as if it were a custom component. See this thread for an example with another core component:

However, I’m not 100% sure this would still work with config flow, so maybe it’s better to just wait.