Looking for advice on the best way to turn of HVAC on second "home" based on event in primary "home"

I’m looking for some ideas on how best to skin a cat. In this case, the cat is two distinct homes that I would like to have an event from one home trigger an action in the other home.

Wordy version:
My property has an in-law-suite that is running on its own VLAN, HomeKit and HomeBridge install right now. My main network is running HAOS (2024.5.2) on a dedicated rPi, HomeBridge and HomeKit. Both “homes” use ecobee for thermostats and I do have the API key for both accounts. My home thermostats are available in my HA instance but I’m unable to see the other one. My property also uses Tesla Powerwalls for backup power. I have an automation that turns off my HVAC systems on grid down.

This doesn’t apply to my in-law-suite though because it is on its own home and isn’t currently visible in my HA install. What I would like is to be able to have the grid down trigger HVAC off on the other thermostat.

Right now my thought is to install a HA VM on that VLAN and pair the other thermostat to the HA VM. Then I’m still at somewhat of a loss as to how I actually make the grid down trigger the automation since they don’t talk. Send a webhook to the other home’s future HA VM maybe? Install MQTT on it and send a trigger via MQTT to it? I can send from my network into the VLAN.

We want the homes to stay completely independent for the most part. There are three Tuya switches that both homes can control for shared outside lighting. They are shared though because of the external connection for Tuya instead of HomeKit/HomeBridge/HA.

Maybe I can look at a trigger directly to the ecobee API for the other home account instead. Then my automation would be able to sent the trigger, if that is even an option. I’m not much of a coder, but I can typically modify what someone else has done to work for my needs.

As of right now, this is my automation:

alias: GridDownNoHVAC
description: Turn off HVAC systems when grid goes down to conserve power.
  - type: not_powered
    platform: device
    device_id: 1a9ca05xxxxxxxxxxxxxxxxx6d3c72a
    entity_id: 1b26ed6xxxxxxxxxxxxxxxxxd65bcd85f
    domain: binary_sensor
      hours: 0
      minutes: 0
      seconds: 0
condition: []
  - service: climate.set_hvac_mode
    metadata: {}
      hvac_mode: "off"
        - 509921fxxxxxxxxxxxxxxxxx70519a39
        - 1343eexxxxxxxxxxxxxxxxxd111c26f
mode: single

I figure we can manually turn the HVAC systems back on when we want. This way they don’t burn up our batteries if we don’t even know the grid went down.

As somewhat of an aside, I was going to ditch the HomeBridge instances but the Unifi Protect integration with the doorbells and HomePods alone are enough of a reason for me to keep it for now. Maybe I’ll be able to get it working as I want it in HA… but that is another topic for another time. I started with HomeBridge before adding HA to my home last year and have been migrating things over to HA as time/learning has allowed.

If you have questions for me please do not hesitate to ask. I think I covered my end goal clear enough, but to close out:
How can I have a grid down event trigger HVAC off on the other thermostat?

I use Remote Home-Assistant, it allows me to use sensors and devices from remote HA instances (can be VLAN) and run automation and tiles on one machine. I believe this can help you.

Thanks for that tip. That would be going the route of setting up a HAOS VM for the in-law suite’s VLAN. I’ll look at this as an option for sure. Thanks.

New problem has come up. The other home has that thermostat on its own account. That account isn’t a developer with ecobee already, so it won’t be able to until they open developer registrations again.

So now I’m thinking I’ll remove it from their account and add it to my account. This will mean my HA install will see it through my existing developer account. Then the question comes how can that “home” have just it exposed.

It is predominately HomeKit run. iPhone, iPad and HomePod for voice controls. I’m going to try to leave it on the VLAN it is on when I add it to my ecobee account in hopes that it will be able to stay on that home’s HomeKit install.

The biggest factor is I don’t want that home being able to see or interact with my home at all.

I ended up resolving this tonight. Since I wasn’t able to add developer to the other thermostat account I tried adding it to mine. This worked well and all I had to do was go to the thermostat settings (on the thermostat) and reset registration. It had me re-add it to Home(Kit) on the second home with their Home app and on their VLAN/SSID. Then it gave me the ecobee registration code and I added it to my account with the ecobee app.

This populated the thermostat and sensor in my HA instance and the thermostat stayed in their Home(Kit). Bonus is that it also retained is settings and schedules!