Lost all zwave battery powered devices

Well, that didn’t go to plan.

I just tried to add battery level monitoring to my zwave network.
I tried with a single device first up, borrowing technique from here:

I have a hass.io on Ubuntu system.
I restarted home assistant to bring in the new sensor (and automation).
And… lost all my zwave devices. Gone. “Error: Entity Not Found” badges everywhere.

At first I thought it was a USB device issue… ACM0 vs ACM1 or something… but no… putty’d in and all looks right and hardware under hass.io, system tab looks ok.
(I have 40 odd zwave devices and my system is usually pretty stable… USB device name issues are my most common problem and that is not common)

After poking around, zwave integration menu was present but showing no nodes… I thought a restart of hass.io might get me going (don’t judge, we all do it)…
And after that the controller (Aeotec zstick) came up but nothing else.
Looking at the OZW log and there is communication happening… to many nodes, but still they all show Not Found.

I commented out the new battery level sensor and gave it another restart.
This time, after a little while all powered nodes came back… and only one battery powered node… a Dome Siren… but it’s entity ID (name remained unchanged) and all it’s child entity ids and names reverted to default.

None of the other zwave device entities for battery powered devices are found.
6 x Aeotec MS6, 1 x Vision Door Sesnor, 2 x Fibaro Motion.

The OZW Log is showing communication with these nodes if I activate them.

Very odd.
If someone has a suggestion regarding possible cause/fix, I’d appreciate it.

Still not sure what happened, exactly.
Backed up config folder, rolled back a week old snapshot (which came back normally) and slowly rebuilt what I had done over the past week including the battery sensor.
Everything went fine.

Highly suggest keeping regular backups of the ozwcache_0xabcdef.xml file.

Thanks for the tip, mate.
I did a search for ozwcache*.* from \config and got no hits.
I do have zwcfg_0xc0103fc9.xml (I imagine the hex part changes from install to install).
I am still quite the noob, really… I have learned a lot already but it still feels like I’m only 10-20% down a very long road…

So, if you don’t mind, your response prompts a couple of questions…
(The obviously one…) Where is that cache file?
How to use it… is it the sort of thing I can just restore and then restart HA?
Should it be restored while HA is down followed by starting HA up again?
Is it safe to restore this file when there have been changes to the zwave network (say a node was added/removed)?


I have a portainer container, and just used that to get quick access to a shell on the home assistant container (still haven’t searched out where all the hassio docker business is installed etc…).
Couldn’t find the cache in there either…

The zwcfg_0xc0103fc9.xml is the correct one.


While down then start up HA

When you add/remove a node hit the Save Config button it should update the xml then back that new copy up.

The XML is in your config directory.

1 Like

Thanks firstof9.
Appreciate the response and advice.