Lost entity; restore backup doesn't fix it; cannot reconfigure

Hi Folks.
For reasons, I decided to remove a faulty entity, remove the integration and them reconfigure it.
When we reinstall the integration, the entitiy that was deleted before doesn’t come back.
so I decided to restore a full backup from a few days before.
That didn’t restore the deleted entity and I am running out of options on how to bring it back.
I run my HA in a HA blue unit.
I am thinking about factory reset (reflash???) my HA blue and restore the backup to it after first setup.
I tried delete the config folder via samba and reinstall back up but didn’t work either.
Any ideas?


The first thing i’d do is check your logs and see why it wasn’t created when you added back the integration. There’s no real info here for anyone to really help you.

I could not find anything in the logs related to that.
also, why the full backup dind’t restore to previous conditions? (i.e with entitiy before deletion)
It’s a camera, it should create teh device with 3 entities (videosd, videohd and motion) - motion was deleted before and now id doesn’t create when I reconfigure it.

SOLVED. See ODROID-N2+ full image (OS + HA)