Lovelace add clickable url?

Hello guys,

I want to add a url-list (clickable url’s) to lovelace. I tried weblink but the url’s i add are NOT clickable. Could someone give me a hint? (please state in which file i should add/edit…)

Thnx!

ps: i tried this in configuration.yaml

weblink:
entities:
- name: Router
url: http://192.168.0.1/
icon: mdi:router

In lovelace-UI (0.84.6) i added a entities-card (choosing: weblink.router)

ps2: in the editor (Toggle editor, in lovelace UI) is looks like this;

type: entities
title: URL’s
entities:

  • entity: weblink.router

(strange that the icon (router) is not visable in the UI and not in the code)

try (this tab/view):

title: Weblinks
path: Weblinks
icon: mdi:web
cards:
  - type: entities
    title: HomeAssistant
    show_header_toggle: false
    entities:
      - type: weblink
        name: Home Assistant
        url: https://home-assistant.io
        icon: mdi:home-assistant
      - type: weblink
        name: Configuring Home Assistant
        url: https://home-assistant.io/getting-started/configuration/
        icon: mdi:assistant
      - type: weblink
        name: Available Components
        url: https://home-assistant.io/components/
        icon: mdi:briefcase-check
      - type: weblink
        name: Troubleshooting your configuration
        url: https://home-assistant.io/docs/configuration/troubleshooting/
        icon: mdi:wrench
      - type: weblink
        name: Getting Help
        url: https://home-assistant.io/help/
        icon: mdi:help
      - type: weblink
        name: Home Assistant Forum
        url: https://community.home-assistant.io
        icon: mdi:comment-multiple-outline
7 Likes

if i add it to configuration.yaml i get these errors:

Configuration invalidCHECK CONFIG

Component not found: cards Component not found: path Component not found: title Component not found: icon

my code isn’t for configuration.yaml, it is a Lovelace view…

and, there not mentioning of a card in the code since it uses the native entities card and weblink: https://www.home-assistant.io/lovelace/entities/#weblink

this view looks like this:

3 Likes

THNX! works.

Weblink cards have been deprecated. Suggest use a Markdown card instead:

type: markdown
content: Sample link to [Google Maps](https://maps.google.com)
1 Like

What is deprecated?
A standard Entities card?

Depricated = no longer used.

I know what “deprecated” may mean)))
My question was about a particular person’s post.

I have used entities card for years for weblinks; so I guess he is referring to a specific card; since weblinks are still supported:
https://www.home-assistant.io/dashboards/entities/

2 Likes

I tried to make a link with markdown type but it did not work, is this for a lovelace card?

Marius’ code works a treat, thanks for that!

Sorry for necromancing, but maybe helpful:

If you are using uBlockOrigin(and blocking WebWorkers) then anything using markdown will NOT be shown. Therefore you must have WebWorkers enabled for homassistant if you are using markdown.