Lovelace and sensors showing NOT FOUND

I’ve enabled Lovelace as the default template and everything looks good apart from 3 Hive sensors on the badges bit at the top. I had to get Hive to remove them so that I could re-pair them due to another problem.

Now, just on Lovelace, 3 of them (which I renamed when I re-paired them)) come up as NOT FOUND. If I remove Lovelace as the defaut template and restart HA, they come back again.

I tried deleting my db file and restarting but that’s not helped.

Any ideas?

1 Like

That is interesting, I think I am suffering of the same. In migration to Lovelace I reorganized a lot of YAML files, mostly groups.yaml and history_graphs.yaml, resulting in 5 “Not Found” sensor badges on top of the home tab on the lovelace UI. There is nothing in the logs. How to find out what is missing??screenshot

Same thing is happening here, but after I edited my knowndevices.yaml to track: false.

If you use the new Lovelace UI you can edit the raw code to remove those broken badges.

When editing the UI, click the 3 dots on the right hand side again and press


You can then edit them out

This worked, thanks!

Has anyone opened a bug? I dont think, that it is a feature and should be solved :-).