Lovelace: Bringing back entity-filter (monster-card)

my monster-card-based card is not working after upgrading to 0.90.0 :frowning:

Working for me on 0.90.2

sorry, should be 0.91.0
it is working actually, but for some reason ALL 3 automations that are into that card and control its behaviour were OFF (I did not turn them off and their initial_state: true).
don’t know what’s happened during update.

As soon as I exclude a light group entity (e.g. light.cinema_downlights ) all lights that are on disappear from this monster card:

card:
  title: Lights On
  type: entities
filter:
  include:
    - domain: light
      state: 'on'
  exclude:
    - entity: light.cinema_downlights # <---- add this and no "on" lights show.
show_empty: false
type: 'custom:monster-card'

Does it not support light group entity exclusion?

My ultimate goal would be to have a wildcard exclusion for my “all” light groups. e.g. "*light.all_*" should exclude the entities: light.all_kitchen_lights and light.all_lights from the above card.

EDIT:

Actually excluding any single light entity clears the whole card of lights that are on. Am I missing something?

card:
  title: Lights On
  type: entities
filter:
  include:
    - domain: light
      state: 'on'
  exclude:
    - entity: light.lifx_bar_1
show_empty: false
type: 'custom:monster-card'

EDIT 2: My fault. it’s ‘entity_id’, not ‘entity’. All good.

hello to all
anyway to use this:
type: ‘custom:monster-card’
show_empty: false
card:
type: entities
title: Lights On
filter:
include:
- domain: light
state: ‘on’

but for timers?

Point 3 & 11,

Hello,

is it possible to show entities NOT matching a defined string?
I use the hass.io Google Drive add-on and want to show any alerts which are not the only correct one named “backed_up”.

Thanks for your help in advance!
/ Ralf

Edit: Nevermind, discovered that I needed to remove the “-” before the action. This works now.

  include:
    - domain: light
      options:
        tap_action:
          action: toggle
        hold_action:
          action: more-info

Hi all, looking for some help with config.

I’m trying to get options to work under my filter for a glance card. Basically, I want a glance card that shows lights that are on and tap to toggle them off or hold to get the more-info.

My card config is follows:

card:
  title: Lights On
  type: glance
filter:
  exclude:
    - state: 'off'
    - state: 'unavailable'
  include:
    - domain: light
      options:
        tap_action:
          - action: toggle
        hold_action:
          - action: more-info
show_empty: false
type: 'custom:monster-card'

The card filters and shows entities like it’s supposed to, and brings up more-info by default. I want to have it just toggle rather then this. When I put in the options, tapping or holding on any of the displayed lights does nothing.

Any thoughts?

So, does secondary_info work for anything else than “last-changed” ?
I’d like to use an attribute from the filtered entities as secondary_info, but nothing is displayed when I do that.

I’m using the card to show all ZWave devices and would like to display the last received timestamp of each device.

As far as I can see, the questions higher up in this thread reagarding secondary_info have not been answered yet.

The core secondary_info row shows entity_id or last-changed. You could use this custom card

I’m curious if Monster-Card can help me out.

I have a waste collection card made of a Sensor and multiple binary sensors created from a Google calendar entry.
Currently all the entities show up on the card but I’d love to hide the ones that don’t apply for the upcoming collection day.

Can the Monster-Card always show some entities and then have the others show if they meet the criteria?

For example, I have a sensor which show the collection day as it can change based on holidays so it should always be shown.
The other sensors which are binaries should appear only when set to “On”

Is this possible with Monster-Card?

Check this out

@AhmadK Thanks,

So does the when statement work differently in the Monster-Card than it does in the My-Monster-Card? or did the when statement get pulled over?

It exist only in the latter as far as I know.

only today noticed I had to change the plex setup to the new config integration…

having done that, I need to get back on this post above which I use:

  - type: custom:auto-entities
    show_empty: false
    card:
      type: entities
      title: Now Playing ...
      show_header_toggle : false
    filter:
      include:
        - domain: media_player
          state: /playing|paused|'on'/
          options:
            type: media-control
            artwork_border: true
            artwork: cover
            hide:
              icon: true

using the type: media-control I would have thought/hoped this to show the full media-control card as if it would be used separately , but instead it shows a tiny media_player interface:

09

compare that to what the

  - type: media-control
    entity: media_player.plex_telefoon

does:

58

is there any way we can set any of the auto-cards to show that?
thanks!

btw using the conditional card explicitly on this entity does work:

  - type: conditional
    conditions:
      - entity: media_player.plex_telefoon
        state_not: 'unavailable'
    card:
      type: media-control
      entity: media_player.plex_telefoon

Hi Surge, did you ever manage to get this working? I would love to do something similar. Cheers.

HI, just ran into this, but testing it errors out. Is this still a valid config?

It contained a typo in the indentation of the last two lines.
Fixed.

my pardon for this silly post, but thanks for fixing. Should have seen that myself…sorry

gives me opportunity to ask about the templates: can we check state: versus a template?

domain: sensor
state: > {{states'(input_number.frontend_value_set')}}

of not, would you consider a FR for templates?

Need to bump this, because of HA 107.5… really sorry

this has been working ever since it was posted here:

  - type: custom:auto-entities
    show_empty: false
    card:
      type: entities
      title: Now Playing
      show_header_toggle : false
    filter:
      include:
        - domain: media_player
          state: /playing|paused|'on'/
          options:
            type: custom:hui-media-control-card
            artwork_border: true
            artwork: cover
            hide:
              icon: true

but now we get the red card on the custom:hui-media-control-card .


Is this something you are able to fix any time soon / at all @thomasloven ? You see I did try the Lovelace-card-preloader, as it appeared to be the only auto-entities card config that doesn’t work in my config, but though I saw a card appear once, like this:

it became red again immediately after that. Really hope you can have a look at this, because this improvement in HA, isn’t really appreciative of the given card config…

thanks for having a look if you would.