Lovelace card edit bars gone

I updated from 0.104.0 to 0.104.2, started adding some cards, and now this:

I can’t delete or edit cards from the ui now. Dev info says I’m in storage mode, and this is happening on all of the tabs. Restart and reboot don’t fix it. Any hints on how to fix it?

F’ ‘n A’!!! I refresh the page, login, and it works fine. Why would be the next question?

I had a similar issue three (edit) dots not showing. Log out/in fixed the issue and my guess would be an issue with user rights.

It happened to me today… same thing, after update to 2021.7.1 this morning. No edit links in any card, in any of my lovelace boards, exactly like picture in first post. I don’t have YAML mode.
Same on chrome, edge, android. Log off/on doesn’t help. I deleted all browser history, coockies, nothing. Then i changed theme in personal settings from “backend selected” to some other i have instsalled and even more weird things happened: half of text was missing in my settings page. Then i pressed shift+F5, text came back and edit links also, but only in chrome and edge but no in android phone. After some additional “tinkering” now all is fine on phone also. Until…when…?
Any clues what could be wrong?

I have exactly the same problem with 2021.7.1. No edit bars. If I revert to 2021.6.6, then they return. Tried clearing the browser cache, logging out and in, changing the theme. None of these worked for me.

This sometimes happens to me (on Container rather than HA OS).
When it happens I find that navigating to another view in the dashboard (while still in edit mode) and then back to the view I want to edit makes the edit buttons appear.

1 Like

Thanks. Yes, tried that too! You’re right I’m running as a container. The only workable solution was to roll back to 2021.6.6. Edit buttons immediately reappeared.

I found “kind off” solution: when i open browser usually edit bars are missing, then i go into my first (default) view, click “edit” there (until now edit bars always show there), then i go back to previous lovelace, click “edit” again and bars now appear.

BTW… i’m NOT in containers, but inside Synology VM.

I guess it’s kinda bug here…

If you change to another tab (view) while in edit mode, the bars will come back.

2 Likes

I just wonder… did anyone reported this bug yet? There were two updates already and this bug still exists and it’s pretty annoying (i don’t know where to report…)

Thanks, this worked for me. Problem exists with core-2021.7.3

Problem exists from 2021.7.0 on, i believe. And it’s starting to become annoying…

This issue has been logged:

and

I use layout-card and confirm that it is directly responsible for this behaviour/bug on my instance.