Lovelace climate showing in celsius instead of Fahrenheit

I am using a Go Control TBZ48 thermostat in Hassio 0.82.1 using an Aeotec Z-Wave Z-Stick Gen5 stick, I was able to make the thermostat work by adding the proper CommandClasses to the zwcfg_*.xml file, however on the Lovelace UI it reports in Celsius even though my thermostat is set up in Fahrenheit, I can’t seem to make it report in Fahrenheit. I tried adding the unit_of_measurement property into the customize.yaml file for the climate entity and the thermostat temperature sensor… the sensor changed to Fahrenheit but the Lovelace UI still shows celsius. Any body has an idea on how to fix this?

Let’s confirm the basics before we dive into debugging it. In your configuration.yaml, what do you have set for unit_system? Is it imperial or metric?

homeassistant:
  unit_system: imperial

Boy do I feel stupid, I missed that… I had it in metric :sweat_smile:

The default for unit_system is metric. That’s fine for a majority of the world but for fans of the imperial system (USA, Liberia, etc) overlooking to adjust it can later prove to be a headache.

Anyway, don’t you wish all problems were so easy to fix? :slight_smile:

Yes! Thank you for the guidance… still new at home assistant but learning quick :wink:

Sorry to revive the old topic. I think I’m having the same issue.
Not only did I previously have the standard unit_system: imperial set, but I’ve since switched to the new GUI based configuration and again set my unit of measure to imperial, but my Climate card is still showing metric for the setpoint.
It does however show imperial degF for the current temperature.

image

Config:

My thermostat is coming over MQTT from Hubitat.
I’ve asked the MQTT Application developer on the Hubitat side if there’s maybe something telling HA to read the value in degC but he and another user of his application feel it’s on me and HA, which I’ll gladly admit it’s probably me.

Any help would be greatly appreciated, thank you.

The problem I have is the thermostat is showing F but the number is really celsius

I tried to change it in the z-wave from C to F but only reverse the current temperature / target any help?

1 Like

I am having this exact same issue, did you have any luck solving it?

Edit: It seems to have just cleared itself up after a few hours? Strange, but I’ll take it.

Also same issue. My climate entity is via MQTT.

Very same issue.
My settings are metric, but temperature shows in F.

Same issue here. MQTT temperature sensor with simple thermostat. One of the updates caused this.

I’m having the same problem as SlyvainVegas, fourzees, meichthys and Jiant_Tree. If I have an entities card showing the climate entity associated with the thermostat, it also shows the same value for current temperature, with the same issue. Trane XL624 thermostat connected by Z-Wave.

Says-Fahrenheit-But-Number-Is-Celsius

Edit: Solved the problem by installing the Z-Wave JS to MQTT add-on as per https://github.com/hassio-addons/addon-zwave-js-ui/blob/main/zwave-js-ui/DOCS.md and setting preferred scales for temperature, air temperature, etc. to Fahrenheit as described by freshcoast in https://community.home-assistant.io/t/z-wave-thermostat-reporting-c-as-f/373566/5. If there’s any way to do it without zwavejs2mqtt, using just the basic Z-Wave JS integration, it’s beyond me.

1 Like

This issue was driving us bonkers. What you suggested fixed it for us. Thanks for pulling those links together!