Lovelace>dashboards>filename to support file navigation

Hey guys!
I’m trying to migrate my ui-lovelace.yaml into different dashboards.
It seems like


does not support file navigation.
I tried using it like this: My custom dashboard is located here: config/frontend/dashboards/overview2.yaml I added

      mode: yaml
      filename: frontend/dashboards/overview2.yaml
      title: Overview2
      icon: mdi:view-dashboard
      show_in_sidebar: true
      require_admin: false

to my configuration.yaml but I can see the filename it is then looking for in Configuration>Lovelace Dashboards>Dashboards under Overview2 is frontenddashboardsoverview2.yaml instead of navigating to the overview2.yaml file and reading it from there I get the default lovelace generated ui. It would definitely help keeping things organised! Thanks for making HA possible! :fist_right: :fist_left:

it most likely does but you’d need to whiltelist the directory or place it in the www folder and idenfity it as /local. I can’t verify at the moment, but most of HA works this way.


drop it in config/www/dashboards/overview2.yaml
call it out

filename: /local/dashboards/overview2.yaml

Hey petro! Thanks for the quick reply on my feature request.
The overview2.yaml loads correctly if I place it in config/ but not at all if I put it in my own folder i.e. config/frontend/dashboards/.
I tried placing the overview2.yaml in config/www/dashboards but still getting the default generated UI

I too tried to get this done - and it seems that config root is always the location, no matter what path I put in-front of the filename.

1 Like

I’m going out on a limb and say why have it at all?

All that the file in question really needs to have at the moment is:

title: Test
views: !include_dir_list ./lovelace/test

You could just as easily add views: as part of the dashboard object and rename the title to something like name: (because the dashboard object already has a title property)

Hey guys! @petro you’re right, you need to place it in the www folder but the path required, not the local prefix.

So if you place your yaml file to config/www/dashboards/overview2.yaml you must configure the filename as:

filename: www/dashboards/overview2.yaml