Lovelace difference between Chrome on OSX and Chromium on Raspbian


I’ve something strange since upgrading to 0.91.1. My runs on a VM and I use a combination of web browsers (OSX, Raspbian, IOS) and apps to access Home Assistant.

Since upgrading to 0.91.1 (and now 0.91.4) when viewing the overview:

  • On OSX and Chrome - All appears in one large screen with no tabs in regular mode
  • On OSX and Chrome in incognito - All appears as normal with separate tabs and items
  • On OSX and Safari - All appears and normal
  • On Raspbian and Chromium - All appears as configured with separate tabs and items
  • On IOS devices using the app - Same as Chromium, all works

I’ve tried clearing the cache, deleting extensions, etc. No luck with chrome.

Any ideas?

You could be looking at the ipaddress/states/default_view web page instead of the ipaddress/lovelace/default_view web page for the one with everything on one page.

Check your links / bookmmarks. Also check the development tools info panel and make sure the big button above the system health box is set to lovelace as default for the browser that is showing everything on one page.

1 Like

I go straight to the name:8123/ and do not enter anything after.

Have a look at the link in the address bar after the page loads.

It was.

Read through some other posts on similar issues and the solution was to remove Chrome completely and reinstall.

That seems to have fixed it. Painful as I use advanced security (Google) but it’s working now.