Lovelace sensor card: line_color attribute ignored in 0.84


I just switched to 0.84.1 and dropped my current ui-lovelace.yaml into the raw config editor window.
Everything seems to work fine so faw, but for some reason the line_color attribute of sensor cards seems to be ignored.
For example, I’m combining two sensor values in a vertical stack card:

      - type: vertical-stack
          - id: be5b2df01bf84fe398f1231b0aac2d73  # Automatically created id
            type: sensor
            entity: sensor.fibaro_fgms_livingroom_temperature
            name: Temperatur
            graph: line
            hours_to_show: 24
            accurancy: 48
            line_color: '#F95454'
          - id: 00ae98c094ac49dc8b9ba932f4fc0789  # Automatically created id
            type: sensor
            entity: sensor.fibaro_fgms_livingroom_luminance
            name: Helligkeit
            icon: mdi:brightness-7
            graph: line
            accurancy: 48
            line_color: '#00A9F0'
            hours_to_show: 24

The cards show up, but instead of the lines being red and blue, they’re both the same kind of orange.

Did I miss a change here?


Yes, you did. :upside_down_face:

Ah, thanks for that! Hadn’t noticed that there’s a separate Changelog for Lovelace.
Anyway, so those config options were just dropped and there’s no way to cusomize the line color anymore?
Unfortunately the corresponding docs page is not up to date.


Pull request made to update the docs.

1 Like