Lovelace UI loads very slow on 0.81.0

Hi, today I updated my Raspberry Pi 3+ with HassOS to v0.81.0.
Now the Lovelace UI loads significantly slower then before the update and much slower as the old UI.
Did anyone experience the same? Or is it just me?

Edit: the UI is not very grafical. Just one picture cards.

For me lovelace was always significantly slower the older UI

Especially with the ios app, the slowness of lovelace is very apparent.
After opening the app subsequent loads take no time in old ui and takes around 4-5 secons on lovelace.
First load is also 1 sec vs 4-5 seconds. I am back to the old ui and will wait until lovelace is not experimental anymore.

Yes its very slow on iOS devices. But I think it’s much slower now.

Lovelace loading performance is notably better since moving my installation from pi3 to a VM. Still not as fast as the “native” UI however.

Definitely noticing Lovelace being slower on 0.81.2 compared to 0.79

yes! I stopped using Lovelace because its so slow now.

Yep. It has always been slower than the default UI, but it seems slower since 0.81.

Yesterday I moved my Home Assistant from Raspberry Pi 3+ HassOS to a VirtualBox VM HassOS on a MacMini Early 2012. Everything is so incredibly fast, its unbelievably including Lovelace!! :smile:

1 Like

i really think to move my hassio too. but always running a mac mini for that is lot of power consumption.

Do you think the raspberry pi is to „slow“ for lovelace? i can‘t belive that

lets hope for a clearing update

Dont understand me wrong. The HA is running great in the Raspberry Pi 3, I running this for 2 years. Just Lovelace (and some other services) are slower then the old UI.
I already runing my MacMini 24/7 for servers so its not a big deal for me.

faster since 0.82

Still quite slow on 0.84. The thing that bugs me most is that when I change tabs the cameras reload. It takes 8 seconds to see a still image. In the old gui the image just stays there. This makes the ui much more fluid. Is this a common behaviour and is there a plan for a fix ?

Hi, still very slow on iOS devices. Please, fix it.

I run iOS and it’s very fast, but I don’t use a raspi. When I was using my raspi, it was very slow. You may want to upgrade your hardware. Mine loads in under a second.

Guys, wondering if this got resolved, because my instance of Lovelace default view HA on RPi3 is very slow to load in 0.89.1 like the OP described. Was slow I think in the previous release too…

No comments ?
Must be just my problem I guess.
It’s got worse, Lovelace takes 5 minutes to load via my PC browser (but MQTT devices and RF switches still work at normal speeds).
Once the view is opened on the browser it performs at normal speed, just takes 5 minutes to open initially, same on Chrome and Edge.

For me it was also pretty slow but its only need a few seconds to load. 5 minutes is a far to slow. Is there anything in the log?