Perhaps GitHub documentation needs updating for some updates card templates? Maybe just a matter of reconfiguration.
I got it working to show a temperature as label, but unfortunately without unit of measurement. How can i simply add āĀ°Cā behind the state?
This is what iām using right now:
label: '[[[ return states["sensor.wohnzimmer_temperature"].state ]]]'
Thank you!
Sorry for not giving more details on the issue. I was at work and replying from my phone. Looks like you know whatās going on but just in case here is what Iām seeing with the graph card and sensor card
I had the same problem after updateing to the latest version. Do a rollback to version 0.9 and everything should be okay again.
Try adding it after the last ]
label: '[[[ return states["sensor.wohnzimmer_temperature"].state ]]]Ā°'
Hey there, I hope youāre all fine.
Iām struggling with different icons and colors based on the current state for the card_graph template. Here is my current try with no effect at all.
- type: 'custom:button-card'
template: card_graph
variables:
ulm_card_graph_name: Temperatur Garage
ulm_card_graph_color: "var(--google-red)"
ulm_card_graph_entity: sensor.klimasensor_garage_temperature
ulm_card_graph_type: fill
ulm_card_graph_hours: 24
show_state: true
state:
- value: 18
operator: '<='
color: blue
color_type: card
icon: mdi:thermometer-minus
- value: 25
operator: '>='
color: red
icon: mdi:thermometer-plus
- operator: 'default' # used if nothing matches
color: yellow
icon: mdi:thermometer
I use a quite equal code for a pure custom:button-card without an template behind and there it works like expected. Thank you for every useful advise
V1.0.1
Yesterday was a bit of a disappointing day with some major issues involved with the initial V1.0.0 release
But we are back today and have addressed and fixed all issues introduced
This release introduces some long-awaited improvements to the backend of this integration with 3 main features:
- Translation engine
From now on almost all strings and states are auto-translated by the HA-core engine and are available in many more languages.
You can add translations by contributing to HA itself through Lokalise - Set Click actions
This feature lets you customize the behavior of all types of click actions (tap_action, hold_action, and double_tap_action)
Please read the documentation on our Wiki.
- Adaptive Dashboard
This newly added dashboard can be configured in the integration setup. It changes based on the type of your device and screen size.
Warning: Please read the documentation carefully through the setup!
Adaptive Dashboard
Changes
Features
- #677 Add Adaptive Dashboard @basbruss
- #721 Ability to customize actions @schumijo
- #728 Added translation engine @13robin37
- #759 Ability to Customize actions (new PR) @schumijo
Code enhancements
- #708 Small tweaks to various default cards @13robin37
- #732 Added/Fixed: The Light Slider can now be dragged! @AndyVRD
- #741 Add Points Per Hour variable (Solves #704) @Neekster
New Custom Cards
- #707 Added Custom Card Nik Tablet @Gilganik
- #719 Added Custom clock Card @Gilganik
- #749 Initial release of a new card named ācustom_card_sisimomo_printerā @sisimomo
Custom Card enhancements
- #715 Add name, icon customization to wsly_pollen card @cmccambridge
- #735 Support percentage_step to custom_card_saxel_fan @schumijo
- #745 Adding feature to ācustom_card_eraycetinay_lockā. @sisimomo
- #744 Adding feature to ācustom_card_esh_welcomeā. @sisimomo
Bug Fixes
- #703 Fix regression introduced by 75d4276 in translations @oscfdezdz
- #709 Updated Indentation to Map Pop-Up @T1ppes
- #733 Fixed indentation for tablet restart control @zerosottozero
- #730 [card_scenes] Fix template name interfering @basbruss
Translations
- #755 Add Finnish translations @ronijaakkola
- #750 Add Brazilian Portuguese Translation to UI @LeandroIssa
- #728 Added translation engine @13robin37
- #727 Add translations to custom_card_irmajavi_speedtest @oscfdezdz
Documentation
- #717 [Action] Update custom_cards docs @github-actions
- #710 Update to custom_card_esh readme to include customizations @1337Reaper
- #720 [Action] Update custom_cards docs @github-actions
- #742 Update card_graph.md @Neekster
- #747 [Action] Update custom_cards docs @github-actions
- #763 [Action] Update custom_cards docs @github-actions
Breaking Changes
- The card_person needs an entity specified outside the variables config to work with the new translation engine #728
This also holds when manually updating any custom person card!
See needed config changes
Old config
- type: 'custom:button-card'
template: card_person
variables:
ulm_card_person_entity: person.username
New Config
- type: 'custom:button-card'
template: card_person
entity: person.username
variables:
ulm_card_person_entity: person.username
- Adapting all cards to work with the custom actions means the
show_last_changed
behavior for the binary sensors cards is changed and controlled by a variable:
See needed config changes
Old config
- type: 'custom:button-card'
template: card_binary_sensor
variables:
ulm_card_binary_sensor_alert: true
entity: binary_sensor.garage_door
show_last_changed: true
New Config
- type: 'custom:button-card'
template: card_binary_sensor
variables:
ulm_card_binary_sensor_alert: true
ulm_show_last_changed: true
entity: binary_sensor.garage_door
Thank you so much for helping out to keep this UI awesome
@1337Reaper, @13robin37, @AndyVRD, @Gilganik, @LeandroIssa, @Neekster, @T1ppes, @basbruss, @cmccambridge, @github-actions, @oscfdezdz, @ronijaakkola, @schumijo, @sisimomo and @zerosottozero
Yes you can put the unit behind it or extract the unit attribute to make it more uniform useable
label: '[[[ return states["sensor.wohnzimmer_temperature"].state + "Ā°C" ]]]'
or
label: '[[[ return states["sensor.wohnzimmer_temperature"].state + states["sensor.wohnzimmer_temperature"].attributes.unit_of_measurement ]]]'
Probably missing one of the easiest things
I have a generic card, but Iād like to change a name of the entity on just this card
Is this possible?
I tried something like the following without succes.
- type: "custom:button-card"
template: card_generic
entity: sensor.aeotec_door_sensor_schuifdeur_battery
name: "Schuifdeur"
Already tried name, label, with quotation marks, without, ā¦
And no, I donāt want to change the name of the entity in my general config.
Hey @Bertvw ,
try it without quotation marks and refresh the dashboard.
- type: 'custom:button-card'
template: card_generic
entity: binary_sensor.wassersensor_kuche_water_leak
name: KĆ¼che
The result without name attribute and with it.
Anybody got some tips on fixing the layouting on conditional chips ?
I am in the same situation as you. Removing the quotes as suggested by @Steffen1988 does not solve the problem.
Also in my dashboard I have several card_generic where I donāt want to show the sensor name.
For example, in the following card the name of the sensor should not appear and instead it happens ā¦
- type: 'custom: button-card'
template: card_generic
entity: sensor.netatmo_home_inside_humidity
name: ""
icon: mdi: water-percent
Even if I insert a space between the quotes, nothing changes. The sensor name appears the same.
The same happens for the following templates:
- card_generic_swap
- card_graph
- card_battery
- custom_card_nik_nas
- custom_card_damix48_power_details
- custom_card_apexcharts
I specify that obviously I have tried several times with the dashboard refresh.
Iāve just opened an issue on GitHub
I am having an issue with card_nik_tablet as it does not seems to want to work properly, can anyone help??
The portion for the battery bar is throwing an error that the custom component does not exist even though it does, the custom:bar-card functions correctly outside of the minimalist ui, in normal lovelace.
are there any steps that I need to take to get it to work withing minimalist??
For some reason it would not load it as a resource from HACS, I had to manually download the .js into minimalist \config\custom_components\ui_lovelace_minimalist\cards
I did a lot of work figuring out a workaround for conditional chips. Take a look at my comment here: Lovelace creates "empty" column for conditional cards when cards are not shown Ā· Issue #6632 Ā· home-assistant/frontend Ā· GitHub
Iāve also made improvements since then, using flex-wrap
and row-gap
to make it work better (adding wrapping if there are more than can show on one line). I just updated to add details about that at the bottom.
Iām seeing the same behavior.
Hello, can you help me to change default icon of Binary Sensor Card.
here is my code :
- type: 'custom:button-card'
template: card_binary_sensor
variables:
- ulm_card_binary_sensor_alert: true
- ulm_show_last_changed: true
entity: binary_sensor.porte_entree
icon: mdi:door
But it still with the defaut icon.
Bar Card is never been part of the resources of Minimalist. It always was needed to be added manually to HACS frontend.
For those having the same issue. This is a not immediately accounted for consequence of rewriting the cards to a new framework that fits the needs of the new custom_actions. In the upcoming releases we will fix the behavior by adding customizable variables (like in the light card)
Yes, this is exactly the same issue I have with a small twist from my end. Beside the conditional card per chips I have a second conditional card for the horizontal stack keeping the chips together, because there are edge cards in it and I want to hide the horizontal stack in case there are no chips to display. Iwas able to edit the code on-the-fly in Chromeās debugger, which resulted in a left justified row of chips, but caused a new problem, which is the shrinkage of the chips, where beside the MDI icon I have some texts. I will keep an eye on the linked topic to see when a generic solution becomes available. Thank you for your directions.