Lovelace UI released!


#62

You can go to the about page And change the default for the Interface from Lovelace back to the standard so that’s at least something for now.


#63

Well this is strange. After editing all the devices in Vera to ensure none would come through with problematic names, this still didn’t fix the issue for me. I reverted to 0.85.1 so I could get a list of all the missing device IDs, and then returned to 0.86.3. Lo and behold, all the devices are now coming through!


#64

Looking good, thanks, with just a couple of minor issues due to some changes to the backend system. Firstly had to remove any double underscores (used in time_date - https://github.com/home-assistant/home-assistant/issues/20433), and secondly change “platform: time” to “platform: time_pattern” where I had a timer for a set number of minutes rather than a specific time (hint - also check /packages if you use that). Now I need to work out how to best take advantage of the new UI!


#65

Upgrade to 0.86.3 went smoothly and have changed over to Lovelace without much problem.
One issue I did come across, is using Entity Card for Remote.

cards:
  - type: entities
    title: Remote Control
    show_header_toggle: false
    entities:
      - remote.sharptv 

I don’t get a toggle button/switch for this entity. In its place it shows the state (on or off).


#66

After upgrade my Hass looks exactly the same, no lovelace gui. I have done what you SUGGESTED and no lovelave gui still. Yes I have cleared cache, removed Lovelace from config.yaml and also run incognito.


#67

How do you know it’s not Lovelace?

The idea is that when you upgrade it converts your old layout to Lovelace…it’s the default.

So how are you sure it’s not Lovelace?


#68

I did a fresh install of HASSIO and the UI looks like previous. Or am I supposed to create ui-lovelace.yaml because I don’t have it?


#69

Yeah. That’s the point.

Nope.

Have you looked at the three dots menu on the right hand side of the screen? Clicked on CONFIGURE UI?


#70

I see it and I want HA to manage my UI so I clicked “Never mind”.


#71

Which means you are using Lovelace in auto-generated mode!


#72

ok, this is slightly painful. Using the image below as a reference, on your system click the info button in the dev panel as circled with the dodgy arrow, then see what it says as per my other circle. If it says “go to states UI” like mine does, then you ARE using Lovelace

EDIT: ignore the fact that I haven’t upgraded to the latest version yet, I’m currently away and kinda locked out due to some errors :smirk:


#73


#74

Is this Lovelace?


#75

are you getting to your HA GUI by using an address with ‘/states’ on the end? ie: and old bookmark? because that will force you to the old GUI


#76

nope. You have /states in the address


#77

I noticed just now that it is only broken on the desktop for me. I can’t click the title of a card with light in to adjust them all in either Chrome or Firefox but it works in Safari on my iPad.

Edit: not that simple after all
it is broken in the home-assistant ios app and fails to load at all in safari on an iphone


#78

:man_facepalming:


#79

With the UI Editor there doesn’t appear to be a way to either add or edit cards in a horizontal stack or vertical stack (or any card which has child cards) other than editing the raw YAML. Is support for this planned?
I’ve just tried switching to using the editor, but this is making editing difficult as I have a number of views which are defined with panel: true (which also requires raw YAML editing, as it is not provided as an option in the editor) with the cards nested in other cards and so I need the raw editor to edit them all.


#80

What will happen to the older Polymer UI now?


#81

You can always access the old UI by going to /states. So if your url is http://HypnoToad.duckdns.org:8123 then going to http://HypnoToad.duckdns.org:8123/states will get you back to your old UI.

You can also set each device you are using to default to the old UI if you would like.

If you are editing the lovelace page using YAML mode, you can also add the following card which will open your old UI:

      - type: entities
        show_header_toggle: false
        entities:
          - type: weblink
            url: /states
            name: "States"
            icon: mdi:home-assistant