Lovelace UI released!


#41

I don’t believe any of the entity ID’s related to my automations changed - they’re the same as pre-upgrade.

The entity ID’s for my hue motion sensors did change, but they’re not triggers for automations. At least it was an easy “fix”!


#42

They don’t have to be triggers… if they are part of a condition or action same thing. It’s worth checking.
Time and Time_pattern can also cause issues.


#43

I’m about to test the new Lovelace UI.
If I want to use custom cards from the community can I still use the included UI editor or should I stick to the yaml configuration file?
Thanks


#44

You can use the UI, use the raw editor to add resources. The custom cards can also be managed from the UI editor.


#45

Ok, got it.
Thank you


#46

Anyone else had problems with chrome cast no longer being discovered? Just upgraded HA (missed the last update) and on restart my chrome cast is no longer discoverable. Tried to add it again but HA can’t find it at all…

EDIT

Forget that… For whatever reason after an hour of not working it just decided to work… :thinking:


#47

After upgrading to this I have lost most of the devices that were passed through from my Vera (and attached rfxtrx box). It looks like they were all being passed through with entity id’s that included double undersores, such as light.k__island_lights_158. They do not have any such name in the Vera UI itself, this seems to be as a result of the Vera component naming them for HA.

Is there anything I can do to get these to come through differently named?


#48

I wish a per-user based configuration. I would be happy with just different ui-lovelace.yaml files, and for each user a different one


#49

all you need to do is look in your entities list to see what the new name is that HA renamed them to and use those new entity id names instead of the old ones.

using your example the new name should be “light.k_island_lights_158” (one underscore).


#51

Thanks. Unfortunately those devices are not coming through at all now, with any name. My entities list is much shorter than it used to be.


#52

sorry, i don’t use a vera so i’m not sure what you can do to fix it from the vera end.


#53

No worries. I’m not sure how it can be fixed from the Vera end to be honest. This is surely something that needs fixing in the Vera HA component?

I’ve been having more of an investigate, and I see I also had Vera devices working previously that were not being named with double underscores - they’re not appearing now either. It looks like the Vera component is no longer bringing through any ‘light’ and ‘switch’ devices for me, regardless of what they’re called in the Vera config. It is still bringing through at least scene and sensor types though. I’m not too familiar with Python but I’ll try to see if I can discern any reason some types have stopped working and not others…


#54

I just tried to setup the history graph, but it looks like this with me.
Not shure or it has to do with Lovelace but installed it after installing Lovelace.
I think I did everything right.

my history_graph.yaml looks like this

  1_wire:
#    name: 1-wire temp Graph
    entities:
      - sensor.boiler_top_temperature
  toon:
#    name: Toon stroom gebruik Graph
    entities:
      - sensor.toon_p1_power_prod_low
      - sensor.toon_p1_power_use_cnt_high
  schakelaars:
#    name: Schakelaars Graph
    entities:
      - switch.d2
      - switch.everspring_an157_plugin_appliance_module_switch

my groups.yaml section looks like this

  graph_tab:
    view: yes
    name: Grafieken
    entities:
      - group.1_wire_graph
      - group.toon_graph
      - group.schakelaars_graph

and

  1_wire_graph:
    name: 1 wire grafiek
    entities:
      - history_graph.1_wire

  toon_graph:
    name: Stroommeting grafiek
    entities:
      - history_graph.toon

  schakelaars_graph:
    name: Schakelaars grafiek
    entities:
      - history_graph.schakelaars

#55

I would change the name of the 1_wire… stuff to something else just to ease problems elsewhere. Change it to something like “one_wire…”


#56

Is it possible to implement multiple Lovelace instances for end users? for example I want a desktop Lovelace and a tablet Lovelace which will show content depending on how I access.


#57

Yes there is a custom component to do just that


#58

Ever since upgrading this morning I get an for many entity Id… I believe it’s because they have two _ _ ‘s in their name. I’m not even sure to to fix them, some are from my Nest thermostat!


#59

Isn’t this just to change the header? What about the actual entities?


#60

If we were using the beta version of Lovelace previously, do we have to completely reconfigure the ui?? After upgrading, mine is a mess. It looks like the old states UI, but with the option to edit the interface


#61

Mines a mess to and things are broken. So not cool.