Lovelace will not stay as default. Clicking overview shows me the normal /states

in my log: Uncaught TypeError: Cannot read property 'shadowRoot' of null

when inspecting with Chrome console:

lovelace.html:2 Uncaught TypeError: Cannot read property 'shadowRoot' of null
    at lovelace.html:2
(anonymous) @ lovelace.html:2

I’ve clicked >> Set lovelace as default page on this device <<

Is anyone else getting this? I’m on the newest home assistant 0.73.0b6. supervisor is up to date v115. I’m not sure what it could be.

1 Like

I think the hack requires a bit more code and error handling. It worked for me in latest beta but I will get to test it out and upgrade only on Sunday.

I am having this same issue at the moment.

Starting with 0.73.1 this hack will no longer be required. Setting lovelace to default on dev-info panel will set Overview to point to lovelace as well.


That works for everything but it doesn’t work if you’re using Android and add home assistant to the desktop from the pop-up that shows as a web app. That will still show the old states page, not Lovelace.

Known issue. It will get fixed in 0.74, it’s already fixed in dev.


Ran into this issue as well. In the meantime, I am using this Android app “Website Shortcut” to send me directly to the URL.

Exactly what I did

I have updated to 0.74. The problem that does not load lovelace persists

It got fixed in. 74, clear your cache and reset Lovelace as default