Lovelace wont load

Hello all having a bit of a problem here. Anytime I try to load the lovelace ui I just get a white screen. I have tried completely removing the lovelace file from .storage. I set my config to yaml and loaded a very simple ui and still nothing. I have also noticed that anytime I try and load the ui I get the following error in my logs
/frontend_latest/app-3b4bb4ed.js:365:157 Uncaught TypeError: Illegal constructor
11:09 PM components/system_log/ (ERROR)
Any ideas?

Well apart from the standard advice of clearing your browser cache (generally ctrl-f5), it is bloody hard to help someone who doesn’t even say what version of ha he is running.

I was able to solve my “Lovelace Problem” with:

  1. double check of configuration files for double underscores
  2. double check of the automation for the trigger “time”
  3. and almost the most important, empty browser cache and restart browser!

Hope it helps!

1 Like

Thank you for your reply Thomy sadly I have tried clearing cache and checked the config several time and still no luck.

Nickrout thank you for your response cache was the first thing I tried. For future reference posting things in a more professional manner such as “can you please tell us what version of ha your running” makes you seem much more approachable and less like a pretentious prick. I don’t believe anyone comes here to be belittled. Thanks! :slight_smile:


For everyone’s reference I am currently on 86.2 and tried rolling back to 84.3 and 84.2 this morning with no luck still the same problem. I have tried several different love lace configs all very simplified and still can’t seem to get anything other then the white screen and same log error.

There is no such version. All versions of HA start with a zero as in 0.86.2.

Please watch your language too.

Hi all, I have the same problem.

Lovelace doesn’t load in Chrome 71.0.3578.9 (latest official) with Home Assistant 0.86.3 (no, just a regular HA installation on Ubuntu 16.04).
Clearing cache and opening in Incognito Mode unfortunately don’t help.
No other error messages in HA log other than:
<IP-address>:8123/frontend_latest/app-3b4bb4ed.js:365:157 Uncaught TypeError: Illegal constructor

Firefox loads Lovelace frontend without problems and also doesn’t trigger the above error in the log.
Chrome on Android also loads fine.

Hope that someone has a simple solution to this!

I am receiving this exact same issue. Only affects desktop Chrome.

  • Chrome: 72.0.3626.64 (Official Build) beta (64-bit)
  • HA: 0.86.3 hassio for Raspberry PI
  • Hardware: Raspberry PI 3B+

Attaching the client console error output.

Does here.

1 Like

Try clear cache and hard reload. F12 dor dev console in chrome, rightclick on the refresh button and select clear cache and hard reload.

CTRL+F5 sometimes works wonders as well.

It’s working fine for me…

It’s a browser/chrome thing.

Try this:

  1. put this : “chrome://flags/#enable-experimental-web-platform-features” in the url bar
  2. Disable the feature.
  3. Wait for the re-launch.

Thanks all! Indeed it seems to be the chrome flag setting. See also: