Lutron Caseta connection problem


I have been successfully using Home Assistant with a Lutron Caseta L-BDG-WH hub, but recently I had to un-plug both the caseta hub and the RPi that I am using to host Once restarting everything, was able to reconnect with all other devices, and I am able to use my Lutron lights through the Lutron app and through Google home, but not through Looking through the logs I found this:

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/", line 145, in _async_setup_component
hass, processed_config)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/", line 55, in async_setup
await bridge.connect()
  File "/usr/local/lib/python3.6/site-packages/pylutron_caseta/", line 40, in connect
yield from self._login()
  File "/usr/local/lib/python3.6/site-packages/pylutron_caseta/", line 281, in _login
self._reader, self._writer = yield from self._connect()
  File "/usr/local/lib/python3.6/site-packages/pylutron_caseta/", line 58, in _connect
  File "/usr/local/lib/python3.6/site-packages/pylutron_caseta/", line 16, in open_connection
limit=limit, **kwds)
  File "/usr/local/lib/python3.6/asyncio/", line 81, in open_connection
lambda: protocol, host, port, **kwds)
  File "uvloop/loop.pyx", line 1879, in create_connection
  File "uvloop/loop.pyx", line 1858, in uvloop.loop.Loop.create_connection
OSError: [Errno 113] Host is unreachable

That looks to me like the IP address for the Caseta hub was changed when I powered it up again, but I have it set as a static IP in my router, and I have checked and confirmed that it still has that IP address. At this point I am stumped, I’ve tried restarting a few times with no luck. If anyone has run into this before or has any ideas, I am all ears.

I was able to fix this by restarting the rpi running home assistant a few times. Not a clean solution, but it worked.