Lutron Caseta Invalid Config?

Is anyone else having problems with their Caseta Hub today? Maybe their servers are offline… but is has been several hours now.

This component has been working without issue for a month. Suddenly this morning when I rebooted my Raspberry Pi it gave me the following error:

The following components and platforms could not be set up:


Please check your config.

The config entry hasn’t changed. The IP Address is still reserved on my router. The key file and certificate files are all still in the /config directory. And I restarted both my router (it is hard wired) and the Caseta Hub, and restarted Home Assistant. No luck.

  keyfile: caseta.key
  certfile: caseta.crt
  ca_certs: caseta-bridge.crt

Here is the related message from the log.

2018-04-17 08:01:54 WARNING (MainThread) [homeassistant.setup] Setup of config is taking over 10 seconds.
2018-04-17 08:02:01 ERROR (MainThread) [homeassistant.setup] Error during setup of component lutron_caseta
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/", line 142, in _async_setup_component
    result = await component.async_setup(hass, processed_config)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/", line 57, in async_setup
    yield from bridge.connect()
  File "/usr/lib/python3.6/site-packages/pylutron_caseta/", line 40, in connect
    yield from self._login()
  File "/usr/lib/python3.6/site-packages/pylutron_caseta/", line 284, in _login
    yield from self._load_devices()
  File "/usr/lib/python3.6/site-packages/pylutron_caseta/", line 314, in _load_devices
    for device in device_json['Body']['Devices']:
    KeyError: 'Body'
1 Like

There is at least three post on this topic, the problem first started several weeks ago.

It appears that a solution may be forth coming. It seems to have restored service to non-hassio installs so far.

1 Like

I started having the problem when I upgraded from 66.1 to 67.0 hassio

1 Like

Sorry, the duplicate posting was unintentional. Since the problem only cropped up for me this morning I did a quick scan of the top 10 or so posts before I wrote this. Maybe I had been spared thus far because I have mostly been reloading instead of rebooting.

The timing was just disappointing because I rewrote my light automation routines yesterday and somehow my bedroom light woke me up early when my son went downstairs, and my wife has been getting impatient with the inconsistent light situation here.

Thank you for the information.

This is great news. Do you know if the resolution happens automatically for the non-hassio users?

@BrianHanifin I wasn’t trying to give you a hard time about a duplicate post, some had just rang the doorbell and I just typed a quick reply to help.

I think that I was one of the first to run into the problem on March 31th.

@ngknick I am not sure what the process is to get the correct python files added to hassio. They seem to happen fairly quick.

Thanks for the reply, more curious what “fixed” the home assistant users…any idea?

This is one of the places I found. Github Pull Request

Just to follow up. I have solved this problem by ripping the Caseta Hub out of the loop. I paired the Caseta devices with my Wink hub and am back online. It has taken a couple of days to get the bugs worked out, but I think the house is finally almost back to where it was. (For some reason my instead dimmer modules started acting up after this switchover, but it is probably something I did.)