Lyasi/Meamor Smart Bulb flashing?

Hi, I bought the following Lyasi Smart wifi Bulb to try and see if I could make it work with Hass. Just like many of the other Tuya app compatible bulbs it uses a ESP8266 chip, combined with a MY9291 thing. So it should be compatible according to the Sonoff Tasmota Github. However as you can see in the following album There aren’t any visible tx/rx/3.3v/gnd pins/pads on the top and on the boards itself it’s also not written so I have no idea where to attach my cables. Do you have any experience? I know on the ESP chip itself GND should be on the top left, RX/TX on the top right and 3.3v on the bottom right, but it’s all too tiny and crowded to find out if there are points where these lines are accessible.
If there’s a way to directly speak to the lamp using Tuya with home assistant I’d also be content of course.

So the ports that are available to me are (gp)io0, (gp)io2 and RET. I know the chip can go to flashing mode by connecting io0 to ground and I read in the adafruit docs that the io2 can become a Tx port, so what about RET? I can’t find the mention of that anywhere and I can only guess it means “return” or “receive” and thus Rx? I of course don’t want to break the lamp and I don’t know how to power the board to be able to flash it (instead of just attaching the lamp to the power, but that would be dangerous)… So yeah… Any tips are more then welcome updated link to the photos. I also got this nice spec sheet from Lyasi!

I tried flashing tasmota on it (before trying to backup the original rom, which sorta failed as having flashed it back, I cannot connect to the bulb or make it start blinking :/), but the wifi won’t connect. So I’m still figuring that out

Update: I managed to run tasmota on it, but I couldn’t connect it to the leds properly. In the process of figuring stuff out stupid me shorted the circuit. RIP lyasi bulb. It still functions as a dumb light though so it’s not completely useless now.
I think I’ll order a new one though, as the light it gave was really good and I see a lot of progress has been made on tuya-homeassistant

Just popped open a cheap Amazon UK Wifi bulb and after some digging on the forums found this thread from the Cheap UK WiFi Bulbs with Tasmota - teardown help (TYWE3S) one.

The bulb I have is exactly the same as yours @Jolanrensen and it seems you managed to get Tasmota despite having all of the concerns I have about soldering in confined spaces and tiny connections, did you manage to get it fully functional before it went pop and did you buy another in the end?

I would be very interested in hearing how you managed to flash the bulb if you have time to detail it I would really appreciated it.

While it did install (soldered using the spec sheet) I had trouble connecting it to any WiFi network at all and I couldn’t turn on any led using the software. While trying to find out which ports were connected to which led I popped it. I did buy another one on Amazon, however by that time tuya was working on home assistant, so I didn’t bother to flash tasmota on it as it could be controlled by hass already.

I see.

Well, worth a shot I think. Have flashed Tasmota onto 2 RGB strips and a few Sonoffs so far, been really impressed with the responsiveness and reliability through HA. How is the aforementioned with the Tuya component?

Just to check, is it these pins I am looking to solder onto?

Thanks again!

I agree Tasmota is really responsive. The Tuya component is significantly slower.
There are some pins there indeed, but also on the back panel if I recall correctly. If you look at the schematics I posted in the topic you can see which pins do what.

Good luck!

Yep, had a look at the schematic, I just don’t have the device with me to trying to work it out from pictures is probably not the way to go.

Did you need to do anything specific to get it into flashing mode?

From the spec sheet it says:
PWM interface IO12 (R), IO15 (G), IO13 (B) IO4 (W)

Did you try configuring the module in that way in the Tasmota web interface?

I couldn’t get to the web interface because the bulb wouldn’t connect to wifi

OK, I will take a look tonight and decide whether it is worth proceeding. I will let you know.

Thanks for the help.

Google Docs did a surprisingly good job of translating the spec!

Was this correct? Was there any sign it was in flashing mode versus normal mode?

So I flashed this tonight and got to the Tasmota web interface no problem. No light from the bulb though.

I posted asking for help on your GitHub issue, thinking it would keep things in one place (and thinking it would re-open if I did, but it didn’t). Any chance you could re-open it? Otherwise I can just post a new issue I guess.

That’s further then I got! Nice.
I can’t open it unfortunately, someone else closed it, but it can be reopened he said.
Now it’s just a matter of getting the correct LEDs to light up with help of the schematic right? (Try Google translate unless you know Chinese)

Think you must have got unlucky, I added my wifi credentials prior to compiling the firmware and it was connected before I could scan my network for the first time. I was just surprised it flashed, but it worked first time.

Hopefully I will be able to make it work from here, not sure if it using an external chip to drive the LEDs, which is all connected to one pin on the ESP8266. Will post up another issue on the GitHub page and see if anyone can help there.

Will report back.

Hi blawford did you do a backup of the original Lyasi firmware? I have tasmota flashed on this bulb but forgot to do a backup :frowning:

Sorry, I didn’t.