Lyric integration: Addition of leak detection sensors

The current Honeywell Lyric integration does not seem to support their Resideo Wifi Leak Detection sensor. From the Integration page, only Climate sensors are listed.
The Leak detection sensor appears fully supported by their developer API.

Attempts to add the integration do appear to support the leak detector at the Auth page, but the sensor never gets added to Home Assistant, and creates the following error (presumably because it only supports “Climate” sensors and not leak sensors).

Log Details (ERROR)
Logger: homeassistant.components.climate
Source: helpers/
Integration: Climate (documentation, issues)
First occurred: 10:53:08 AM (6 occurrences)
Last logged: 11:00:30 AM

Error adding entities for domain climate with platform lyric
Error while setting up lyric platform for climate
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/", line 438, in async_add_entities
    await asyncio.gather(*tasks)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 589, in _async_add_entity
    device = device_registry.async_get_or_create(**processed_dev_info)  # type: ignore[arg-type]
  File "/usr/src/homeassistant/homeassistant/helpers/", line 312, in async_get_or_create
    connections = _normalize_connections(connections)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 851, in _normalize_connections
    return {
  File "/usr/src/homeassistant/homeassistant/helpers/", line 852, in <setcomp>
    (key, format_mac(value)) if key == CONNECTION_NETWORK_MAC else (key, value)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 129, in format_mac
    if len(to_test) == 17 and to_test.count(":") == 5:
TypeError: object of type 'NoneType' has no len()

1 Like

Do you have any update on this? I haven’t gone through your listed steps to see if anything has changed, but I thought I’d check in here and bump this thread…

I’ve got many of the Lyric water sensors I’m hoping to integrate into HA.


Same result. And the Integration page hasn’t been updated to say it supports Leak sensors.
This post is just a Feature Request, so feel free to Upvote it.

1 Like

Any updates to this at all?

Still not working. Would love direct integration rather than adding via smart things.