[M5Stack AtomPoE with Atom Lite attached] Basic ESPHome setup?

Hi2uAll!

I’m ordered and received a M5Stack AtomPoe (HY601742, W5500) component (with Atom Lite ESP32 module attached). Now I need an basic setup to get things working.

I found some basic information:

As mentioned in the above link, a setup for a PoE Device:

ethernet:
  ethernet:
  type: W5500
  clk_pin: GPIOXX # G22?
  mosi_pin: GPIOXX # G33
  miso_pin: GPIOXX # G23
  cs_pin: GPIOXX # G19
  interrupt_pin: GPIOXX #??
  reset_pin: GPIOXX #??

I found some basic setup:

ethernet:
  type: IP101
  mdc_pin: GPIO23
  mdio_pin: GPIO18
  clk_mode: GPIO0_IN
  power_pin: GPIO5  
  phy_addr: 1

# Enable Home Assistant API
api:
  encryption:
    key: "MpjOHfRgTREDTh3wsqfMvOQmOmy7SN/nALAOXFNLMcQ="

Can I combine one another? Do I need power_pin and phy_addr?

I also found the setup of a pre configured ESP Home Atom Lite:

So I can use, right?

esp32:
  board: m5stack-atom
  framework:
    type: esp-idf

Can anyone please help me or has anyone a basic setup example?

Any help would be very appreciated!

I found working config for ATOM PoE+Atom Lite
But it’s very slow, because you need to set clock_speed: 20Mhz
ping is 700ms

ethernet:
  type: W5500
  clk_pin: GPIO22
  mosi_pin: GPIO33
  miso_pin: GPIO23
  cs_pin: GPIO19
  clock_speed: 20Mhz
1 Like

@klim123123 Thanks for your respond, it’s appreciated!
Can you share your full config of the ATOM PoE+Atom Lite?

substitutions:
  name: esphome-web-acc5c8
  friendly_name: AtomLITE-1

esphome:
  name: ${name}
  friendly_name: ${friendly_name}
  min_version: 2024.6.0
  name_add_mac_suffix: false
  project:
    name: esphome.web
    version: '1.0'

esp32:
  board: m5stack-atom
  framework:
    type: arduino

# Enable logging
logger:

ethernet:
  type: W5500
  clk_pin: GPIO22
  mosi_pin: GPIO33
  miso_pin: GPIO23
  cs_pin: GPIO19
  clock_speed: 20Mhz

i2c:
  sda: GPIO26
  scl: GPIO32
  scan: true
  id: bus_a

pca9554:
  - id: 'pca9554a_device'
    address: 0x27
  
switch:
  - platform: gpio
    name: "PCF9554A Pin #0"
    pin:
      pca9554: pca9554a_device
      # Use pin number 0
      number: 0
      # One of INPUT or OUTPUT
      mode:
        output: true
      inverted: false
binary_sensor:
  - platform: gpio
    name: "PCF9554A Pin #1"
    pin:
      pca9554: pca9554a_device
      number: 1
      mode:
        input: true
#        pullup: true

sensor:
- platform: kmeteriso
  temperature:
    name: Temperature
  internal_temperature:
    name: Internal temperature

# Enable Home Assistant API
api:

# Allow Over-The-Air updates
ota:
- platform: esphome

# To have a "next url" for improv serial
web_server:
1 Like

@klim123123 Thank you so much! :+1:

Do you have the same problem with lagging and huge pings?
Please try to ping your device when it’s connected to ethernet.