Mac OS installation -- failed to find hass_frontend

My installation (on Mac OS running Python 3) seemed to go well enough, but when I run homeassistant I get one error:

ERROR:homeassistant.setup:Error during setup of component frontend
Traceback (most recent call last):
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/homeassistant/”, line 190, in _async_setup_component
result = yield from component.async_setup(hass, processed_config)
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/homeassistant/components/frontend/”, line 308, in async_setup
import hass_frontend
ModuleNotFoundError: No module named ‘hass_frontend’

Any help would be appreciated.

Also, when I get past this, its not clear from the documentation online how I actually start the frontend (it gives hassbian instructions but I’m not using hassbian).

Thank you!

Hi - same problem. I ran the install on this package
pip3 install --upgrade sqlalchemy

ran into the next problem netdisco=1.2.3
pip3 install --upgrade netdisco==1.2.3

then it complained about having to accept the xcodebuild licence so ran
sudo xcodebuild -license

ran the netdisco installation again and the it worked. hope that can help you.

I’m running on a mac and didn’t have to do any of that. :man_shrugging: