Magic Home LED Controller Setup

Tags: #<Tag:0x00007fc3ea595af0>

I bought a few cheap WiFi controllable RGB LED strip controllers on amazon. These are not 2811 LEDs, these are dumb RGB strips. Is there a way to integrate the Magic Home controllers into HA?

I will advise you to break open the controllers and flash either tasmota or esphome on it. This will make them work with HA much much better and you will lose the constant callbacks to some chinese servers.

Don’t be afraid to solder a few wires (as that might sound daunting). But if I can do it (who has zero soldering skills) anyone can do it (really, it’s not a joke).

Trust me it will make those led strips function like a philips led strip!

I had nothing but issues with the FLUX component for these controllers in HA. I ended up flashing esphome.

Thanks. Is this something I can flash OTA with a windows or Mac computer?

unfortunately no it isnt. Magic home controllers need a USB2UART module and you need to get your soldering iron and flux out.

This is a good reference: https://tinkerman.cat/post/magic-home-led-controller-espurnad

USB2UART https://www.aliexpress.com/item/32675598332.html?spm=a2g0s.9042311.0.0.27424c4dqbP765

Thanks. I got them flashed with my FTDI adapter.

I tried to flash Magichome RGB Controller but the solder pad of RX and GPIO came out during soldering. Happened with Sonoff S26 socket as well where one solder pad came out during soldering. What am I doing wrong that solder pad comes off ?

Its a bit late, but better late than never right?
You are probably soldering too hot…
If you have a soldering iron that doesn’t have temperature adjustment, then follow this procedure:

  • clean your soldering tip. Just turn on the iron, wait until it smokes, and use a wet sponge and rub the tip on it a few times. Yes, it will ruin the sponge…
  • When clean, heat up the tip and use a tiny amount of flux…and a tiny amount of soldering tin on your tip. It will start smoking…
  • put your tin lead on the pad you wish to solder… Then with the smoking soldering iron, quickly just tip the pad for 0,5 seconds. This really should be enough… Use the smallest amount of tin possible… repeat for all pads you wish to solder…
  • dip the exposed ends of the wire you wish to solder to the pad in flux and pre-solder it. As in, put tin on the exposed leads… Make sure it “flows” smoothly over the exposed leads…
  • Dip the wire with the tin again in the flux. Now put it to the soldering pad, and again, gently use your soldering iron for no more than 0,5 or 1 second to fuse the wire to the pad…

This really should work. If the solder doesn’t flow, your soldering iron probably isn’t hot enough or dirty.
You can recognise a good and nice solder when it’s shiny and light colored…
The dark colors is usually from overheating.
Always double check after soldering if you have not accidently fused 2 pads together and created a short…

1 Like

Be aware that new version of this board can not be flashed with Tasmota or ESPhome because it does use a new chip. Check out wich chip your board has before anything, to not loose lots of time and get frustrated as I am now. :rage:

1 Like

I did the FuzLed / MagicLight integration and I would like to know how do I change the icon.

There’s a App to Windows developed a few time ago.

Maybe someone could try to inspect the code and make it functional again?
I would like to try, but codding isn’t a ability of me :stuck_out_tongue:

And of course, it work completely fine with me. All functions work as well.

Actually i discover something:

light:
  - platform: flux_led
    scan_interval: 0.5
    devices:
      192.168.0.4:
        name: Fita LED
        mode: rgb

Just deleting the “platform:” make it worked fine to me!!! I’m really happy :smiley:

Can you elaborate on this? I see the “platform” entry in your code. Thx

Sorry, I mean “protocol”!
I deleted this in mine config and works. Hope the same happens to you.

:ok_hand:

This is my code

light:
  - platform: flux_led
    devices:
      192.168.1.214:
        name: LED Controller
        mode: rgb

I restart HA and nothing happens. What am I doing wrong? :thinking:

What is your problem?

The light isn’t showing up or you can’t control them by HA?

I found the entity, then added to Lovelace but with this kind of card:

image

While on the Entities section within Configuration, I see this

If I click on the three dots:

image

The color picker and the other settings are show :man_facepalming: