Magic Home Led Stripe


I’m triying to configure a Magic Home RGBW led controller (esp8285 version)

I’ve manage to assign the 4 channels correctly using generic module type and this configuration

But I cant turn on and off or change the color from Home Assistant. The light card says the light its not available.
My configuration.yaml:

  - platform: flux_led
        name: magichome
        mode: "rgbw"

The mosquitto log says:

1552789919: |-- mosquitto_auth_acl_check(..., client id not available, mqttuser, tele/magichome/STATE, MOSQ_ACL_WRITE)
1552789919: |-- aclcheck(mqttuser, tele/magichome/STATE, 2) CACHEDAUTH: 0

Any idea?

Is that a tasmota config page in your first picture? If so I don’t think that flux-led is the right component once you have flashed it.

Have a look at the Tasmota Wiki for setting your devices up either as auto discovery or manual configuration.
You will need to change every instance of light1 to what ever MQTT Topic setup on your device. It looks like you may have just called it magichome. So instead of "cmnd/light1/POWER" you will want "cmnd/magichome/POWER" instead etc

I didn’t even think it would work as is and I flashed as it arrive :rofl::joy::rofl:

Thanks a lot, now its working flawless