MagicHome CCT RGBWW LED

I purchased a couple of MagicHome Wifi controllers and configured them with HA using the documentation:

the documentation talks about 3 different modes:

Will add a light without the white mode:

    192.168.1.10:
      name: NAME
      mode: "rgb"

Will add a light with rgb+white mode (default). White and RGB channels can be adjusted independently using a slider and color picker respectively.

    192.168.1.10:
      name: NAME
      mode: "rgbw"

Will add a light with white mode only. This is useful when only W channel is connected to an RGBW controller and allows the white level to be controlled via brightness value.

    192.168.1.10:
      name: NAME
      mode: "w"

The problem I have is that my lights are CCT
meaning that they hare both WarmWhite and Cool White

My MagicHome Controller has RGBWW, the code above is only for RGBW, or W
How can I make it WW or CCT ?

1 Like

I have some of the same controllers and use it with my AEGool LED strips. RGBW should work ok. If I can recall you will get a second color wheel to control the white temperature, so it ‘should’ work with WW. However, I found it a bit fiddley to get just the right color temperature.

so HA deals with the controller pretty well, but it’s when I use it on my iphone via homekit, it’s as if it doens’t know how to handle the WW / CW.
It’s almost unusable.

@Mirai_Hayashi @Daniel-san Hey planning on using the same setup.

RGBCCT controller with only CCT LED strip.

Were you able to make it work with HA such that I only have a white color control in HA with temperature and brightness?

How do you like the controller integration and quality? Plan to only use with HA.

Can you turn on lights to a specific temperature/brightness?

Thanks in anticipation.

The controller isn’t that great.
HA aside, using the default App with Google home - it still doesn’t work right.

The Magic App works good. no complaints.

everything seems to work great for the RGB channels.

but my issue is with the WW and CW

if I ask ggl to set the brightness to X% it seems to set the . WW/CQ to 0% and the RGB to X%
which is dumb! because I have nothing there.

in the magicapp, you can configure if this controller is RGB, WW/CW or RGCWWC
I have 4 of these devices, 2 with WW/CW another is RGB and another with RGCWWC
and it jsut doesn’t know what to do with WWC… HomeKit/Google assistant doesn’t know how to deal with it.

I have a similar controller and it seems like the flux led component as well as Google Home doesn’t support RGBWW lights yet. I found a workaround in Home Assistant by setting rgb_color to 0,0,0, and using the white_value to control white brightness. The downside is the RGB LED’s are still on (just dim) and both cool and warm white LEDs turn on using white_value. Still haven’t figured out how to get just the true warm/cool whites to light.

Amazon Echo works the way you’d expect it to. She has 5 presets of white values but no color wheel. Hopefully, Google and Home Assistant get updated.

Any updates about this controller? I have one to and i don’t know if i need to search another one or stick wth MagicHome and wait :frowning:

Nevermind… I’ve flashed it with Tasmota and using all colors succesfully via mqtt :slight_smile:

1 Like

how did you do that

That’s awesome! How did you flash this controller with Tasmota? Link?

U had to solder to gpios. My version doesn’t have RX TX on pcb. After flashing tasmota there was some fun to set Proper gpios to proper colors. When i will be at home i will atach the screenshot for gpios set to proper color on tasmota.

1 Like

@jedi87pl did you have any problems with colour mapping? I just flashed 3 of the RGB controllers with Tasmota, and the colours are all wrong, and I can’t get blue.

Color 1 should give red, but I get off
Color 2 should give green, but I get red
Color 3 should give blue, but I get green.

I’ve tried using a bunch of the SetOption37 commands to change the mapping in firmware, but haven’t been able to find any combination that gives blue.

Wonder if this will work with esphome, I’ll have to give it a play at some point :grin: