Making alexa groups work - the easy way using nabu-casa

Hi All,

long time lurker here (thank you all for your help and contributions) thought i should give back to the community.

I want to share with you the way i over came the issue when using smart switches/plugs in alexa groups.

The problem i faced was that i have a TV connected to a Z-Wave plug and wanted to say to alexa “turn off the tv” and it would turn off the tv in the same room as the alexa device i was in.

If alexa thinks its a switch then you cant control the entity in a group unless you say the whole name e.g. kitchen tv. this is fine if its a light since the alexa app allows you to reasign the device type as a light but we dont want the tv being turned on if we say “alexa lights on”.

after serching the forums i found one solution but though there must be a better way.

after going through the nabu-casa documentation i found the key.

cloud:
  alexa:
    entity_config:

Using this we can present anything to alexa as a specific device.

How to do this:

  1. Delete the device in the Alexa app.
  2. Add the following code in your configuration.yaml
cloud:
  alexa:
    entity_config:
      switch.shenzhen_neo_electronics_co_ltd_power_plug_12a_switch:
        display_categories: TV

replace “switch.shenzhen_neo_electronics_co_ltd_power_plug_12a_switch” with the relevant device you are configuring.

  1. resync your entities with nabu-casa

  2. Get alexa to search for new devices

  3. add the device to the group you want.

  4. Enjoy !!

Hope it helps some people.

1 Like

Hi,
thanks for the input. I am searching for a possibility to do step 5 automatic. Did you maybe find a way to make the group linking automatically?
Thanks for your time.

Greetings.

I’ve tried to follow these steps, but perhaps I’m missing something super obvious. When I add the following section to my configuration.yaml, I’m not seeing any of it take effect. I added the renaming and description to see if I could visually see that it was overriding the config. It isn’t.

cloud:
      alexa:
            entity_config:
                  switch.front_room_lamps_switch:
                        name: Lampy (I had to come up with a stupid name)
                        description: The front room lamps
                        display_categories: LIGHT

Still shows up in Alexa as:
      Front Room Lamps Switch
      switch.front_room_lamps_switch via Home Assistant

First, I don’t see any other “cloud” configuration information in my configuration.yaml file. I’m assuming that adding the cloud section above should be an override to anything else already defined. I added it below my !include statements. I tried restarting the home assistant supervisor to see if that’d help, doesn’t seem to have made any difference. I’m VERY new to home assistant…assuming I’m an idiot and need to be spoken to as such. :slight_smile: