Making my first Automation - On the action "Call service" The YAML I use doesn't stay when I press Save button

I am new to Home Assistant, and making my first automation. For the Trigger I have Ring Doorbell motion and for the action I set it to delay for 2 minutes and “call a service” (downloader) so that I can have it download the last video made into the folder “downloads” that I make on HA.

But when I click the 3 buttons to the right, and select “Edit in YAM” and make my modifications when I press save, the entire automation is saved, but none of the changes I made in the YAML for the call a server downloader remains. It goes back to the default.

I took a screen capture video to show exactly what I am talking about. You can’t see me press the save button in the video for some reason, but it’s a blue button on the bottom right of the screen and I press it.

Also, I have tried this in Chrome, Firefox, Edge, and Brave Browsers. All with the same results.

This is my version of HA

Possibly your yaml is incorrect and it is being rejected.

Have you tried it in the dev tools?

1 Like

Your video is http: not https:
Try editing the whole automation in yaml, click on the meatball menu at the top right.

Good call. I didn’t realize that if the yaml is not correct it wouldn’t save.

I put it in Sutio Code Server and as someone else pointed out, you can’t use double quotes inside double quotes.