Manual install of in web ui panel possible?

Hi there,

Have created a hassbian installation on my Pi and unfortunately no add-on store ( button) is available in the web ui navigation panel. Is there an option to change the configuration.yaml file so that this option is displayed? Or do I need to install an additional package and how?

Thanks for any help,

You would need to install hassio. Basically start over.

You can however, save your config files and add them to the hassio config folder once up and running and everything should restore.

You would also need to hassio: to your config after moving the files over.

to elaborate on what @silvrr said, if you want hassio side panel you have to install hassio, not hassbian.

when you install hassio, you will automatically get a hassio side panel and add-ons store.

You also need to either leave discovery: or add hassio: to get the hassio panel. Discovery is normally enabled by default in all home assistant versions so as long as you have that you don’t need to add hassio:

Thanks silver, will keep that in mind if I need a complete refresh.

Also thanks DavidFW1960, since I’m a newbie I was unaware of a difference between hassio and hassbian.

1 Like

So is that a really the case that you can’t add a side panel of your choice? I have an instance of Node Red that I run on its own docker image, but I like the HACS and add on store for very little things so I went with a VM of Hassio. I wanted to add NodeRed panel of the instance I have separately into my hassio, instead of the using the addon of NodeRed. Can this not be done?

You can add it as an iFrame

Could you then get access to that panel via nabu casa?

Edit: I tried it myself and it didn’t work that there is a clause saying that if using an https site with http sites in the iframe it won’t work so that is why. At least I got my answer