Many integrations broken on upgrade - Config flow could not be loaded

I’m running HA core for a while now on Synology DS216play (DSM6.2.4) + Conbee II with 20 or so lights controlled over Zigbee using ZHA integration. Additionally connecting BMW, Solar panels, Unifi, Lyric
(and Docker is not available for my NAS)

So I decided to upgrade to HA 2021.8.8 for its new features around energy management when it became available in the SynoCommunity. (click & download). And with this install also Python is upgraded from 3.7 to 3.8

But after the install I quickly noticed the ZHA integration didn’t work any longer. Searching the log file for clues… saying “Unable to install package bellows==0.26.0”. Manually trying to install bellows (SSH, PIP) no success… I decided to fully uninstall Python and HA and do a fresh install. Still no luck!!

HA will report "Config flow could not be loaded” .

Then trying to take another step back, I realized that many of my other integrations no longer work either with the above error in the GUI. BMW integration still works, but no SolarEdge, no ZHA, etc…

This hints me that something bigger is going on … but what? any clues where to start searching?

Are you still using the old Synology HASIO package as this has been deprecated:

If so then your options are to use Docker or else migrate to Synology Virtual Machine Manager if your model of NAS supports it.

I recently migrated from Docker to Synology VMM, I never tried the the HASIO package.

I’m using HA from here: SynoCommunity
Normally a very easy install but may not have compiled the very latest release of HA

Unfortunately my Synology doesn’t support Docker. As I understand that would have made my life easier in many ways. Next NAS though…

I encounter the same trouble, with my ds215+ (not supporting docker).
Have you found any solution?
Best regards

Try sideloading Docker - it should work on 215+ very well.

I still haven’t found the solution unfortunately. Possibly my Synology is just too old to be supporting these sorts of app’s so I’m close to moving to a different home automation solution

@BeardedConti regarding the Docker … all the packages seem to be for x64, right? Do you know of any version that will run on 216play with no Intel?

On 216play, no - you can check CPU here:

There is something, that I wouldn’t recommend, but for fun/test/trial you can check here: