Marantz SR 7011 Zones not working

I have no success as of yet. The denon component works a bit (it is working through telnet). But denonavr (using http) not. I saw on Github a topic on using different ports (i.e:8080). The port works in a browser but not in the component

Although I am just trying my way without knowing much about the technicalities of the way these components work, I think I am on to something that might eventually enable one of you to fix the denonavr component so it works with newer Marantz recievers.

If you enter your recievers ip address in a browser like <IP_ADDRESS>:10080 you shold get access to a web interface of the setup menu and where you can also do some very basic operations like turn on and off and select input source.

I then opened the browser inspect tool in chrome and observed what kind of information was sent when I clicked around in the web app. Eventually I discovered the Network tab in the inspect tool and there the REST commands (I think it is?) that were sent.

So far I have identified how to turn the reciever on and off:
GET http://<IP_ADDRESS>:10080/ajax/globals/set_config?type=4&data=<MainZone><Power>1</Power></MainZone>
GET http://<IP_ADDRESS>:10080/ajax/globals/set_config?type=4&data=<MainZone><Power>3</Power></MainZone>

So at least it should now be possible to create some REST sensors in HA for the basic stuff. I will try that now. Oh I guess that is not how this works. Better to create some API call nodes in node-red.

I have the SR7011 working with the denonavr component. I had to change this line in the file found in /srv/homeassistant/lib/python3.5/site-packages/denonavr:


I changed SR60 to SR70 and everything works. The SR7011 is then using port 8080 instead of 80. The only problem I have right now is that my main home assistant device is using docker. And I cannot find the file in the docker system… If anyone can point me to that file location?

1 Like

Did you find the file in the Docker Container? I also have a Marantz SR7011, and have the same issues as you stated, so I’m eagerly waiting to see this fixed :sweat_smile:

Unfortunately not. So it works if you have home assistant in virtual env and can change the file. I asked the author of the plugin to add the SR7011 to the denonavr but no response as of yet.

In the meanwhile i also tried putting the in the custom_components folder like suggested elsewhere (Editing Component Files in Hassio) But the denonavr in the configuration file seems to just ignore that. Maybe you have an idea how to do that?

I just came back to this issue and reading your suggested workaround I gave it another go, and I got it working with my SR7013 :slight_smile:

I created a denonavr subfolder in custom_components for the etc. and then I created an additional denonavr subfolder and put the etc. there, like this:


Then in the i made the suggested addition:


And in I changed the import to:

from .denonavr import denonavr


I’m quite new to HA and can see my Marantz NR1710 in HA by adding the HEOS intergration.
The problem is that not all functions are working. for example the ON/OFF is not working.
I’m trying to follow your suggestion to add the NR1710 to the DEVICEINFO_AVR_X_PATTERN
used this for now


i created a folder ‘custom_components/denonavr/denonavr’ but i don’t quite know what to put in the ‘custom_components/denonavr’ folder.

i don’t know what i should change to the is adding the line enough?

from .denonavr import denonavr

can you/anyone help me with this pls?

1 Like

What setup are you using and which version of HA?
I am now using docker latest HA version and my marantz sr 7011 is working out of the box

Hi Tom.
Thx for your reply.
Sry forgot to mention that.
Hassio: 3.11
HA: 0.106.2
I’m using a raspberry pi with hassio. Latest update.
Marantz is connected to the lan and is discovered by HA but with limited functionality. I can see what’s playing(internet radio), use volume up/down/mute/stop/start.
I even have a script to start playing heos favorite 1.

But I can’t get it to turn on/off.
I do have access by browsing to the IP address. There I can turn it on/off (in a chrome tab) I captured my network and have an URL to turn it ON and one for OFF.
But can’t quite understand why HA is not supporting this.

Have you checked other mediaplayer entities? For my marantz I have two media player entities: 1 is called: media_player.marantz_sr7011 which seems to be generated by heos integration. In that entity I cannot turn off the player. The other entity is called: media_player.sr7011 and with that entity I can turn off the amplifier.

Hi tom,
no the heos integration only gives me 1 entity. (called: “media_player.home_theater” by default)

If i go to Configuration -> integrations -> Heos:Controller than i see it has discoverd the correct device info like model. if i click this line i even see the firmware number.


But did you also include the denonavr in your configuration.yaml? I have this

  - platform: denonavr
    name: SR7011
    show_all_sources: true
    timeout: 2
      - zone: Zone2
        name: Terras1
      - zone: Zone3
        name: Terras2

that is what i had, but comment that part out because i didn’t want it to interfere with the heos integration.
i uncommented now the following

#                                                  #
#              Marantz Receiver                    #
#                                                  #
  - platform: denonavr
    name: Marantz
    show_all_sources: true
    timeout: 60

what i see now in the log (missed that before)

i tried to login into HEOS but i don’t know if that worked.
i went to developer-tools/service

but i don’t get a response i execute it. (also nothing in the logfile)

also the following commands seem to work

Okay, you have to have the denonavr component installed, because I think the HEOS integration cannot turn off the device. So the problem lies in the 403 error. Do you also have _init_py, manifest.json and in the denonavr folder? And you are sure that NR1710 is accessible through http at port 8080 and not 80: You can check at:

Edit: sorry i see that port 8080 is the correct one for you

i don’t quite understand what you mean with “have the denonavr component installed” isn’t that installed by default?

what i did now is downloaded all files from the denonavr folder:
and placed them in /config/custom_components_denonavr/denonavr
i did not edit the files. is there anyting i missed?

looks like the path is still pointing to the default HA folder. i don’t see the ‘custom_components’ anywhere.
after a restart of HA i still see this in the log:

Logger: DenonAVR

Missing status information from XML of Main for: Power, InputFuncSelect, Mute, MasterVolume
8:57:53 AM – components/denonavr/ (ERROR) - message first occurred at 8:56:23 AM and shows up 10 times

I meant that you have to include denonavr in your configuration file. But you do that right now so that is good. I do not work with the custom component option because with my SR7011 everyhing works right out of the box.

Did you precisely follow the post of @Sand? I think you indeed place the items of into folder custom_components/denonavr. And then place in the denonavr folder, and

that is what i did.
the only part i do not understand is his comment below. (i just pasted that line into line 1 of the

And in I changed the import to:
from .denonavr import denonavr