Marthoc Deconz addon - not able to pair entities

Very long story short:
I’ve not managed to add any devices to deconz via the addon with Conbee on my Intel nuc (running ubuntu server and docker). I did however install deconz on my windows computer, and there it works like a charm. After some instructions I paired a few devices (xiaomi button, xiaomi pir, trådfri dimmer (not the remote) and a trådfri bulb in windows deconz. Everything worked fine. I did a backup in phoscon app, put the stick in the nuc and started the addon, restored the backup and restarted deconz addon. On api call for sensors I can see that pir, button and dimmer is indeed showing up, however the dimmer is showing reachable: false. Pir and button is reachable: true. Pir has an entity in hass, but it doesn’t update in either hass or deconz gui. Button however is sending events as I can see both in deconz and in hass. The light is nowhere to be found. Still can’t add new devices.
Have anyone experienced something similar? I have read through the other long threads about deconz but haven’t found anything that could help. I can get debug information from both logs if needed. I just want this to work so that I can get rid of the other gateways…
(I also talked to a guy who has similar problems with not being able to add devices, on rpi3, that tells me the problem is probably not related to me having an intel nuc)
Edit: I also updated firmware on Conbee late last night, after doing a lot of testing during the day, so now I have latest fw.

Just checking - are you using manually installed on the Ubuntu server? I only ask because you say “addon”. If you’re not using, just use the Docker image marthoc/deconz.

My first thought was that deconz wasn’t recognizing your USB stick. But if the remote is sending events then it must be. Can you list the command you’re using to run the container?

Sorry for the confusion. I am using installed in docker, so no underlying resinos. I could of course install your docker image instead of using the addon if you would think that could work better?
I also thought it might be connection problem with the stick first, but obviously not now that the button is working…

Well that would be one thing to try since you have the ability to run normal docker containers.

After discussing with @Robban I tried to add an USB extension between the nuc and the Conbee and that actually did the trick! Probably something messing with the signal. Tried again without to assure that the cord was indeed what helped, and it seems like it.

1 Like