Martin Jerry MJ-SD01 Wall Switch Issues

I’m having an odd issue with my Martin Jerry MJ-SD01 dimmer switch that is running Tasmota 10.1.0. In a nutshell, the physical switch on the wall works well up until it is controlled from within Home Assistant. After it is controlled from Home Assistant, the physical switch no longer works properly. My reproduction steps are as follows:

  1. Reboot the switch.
  2. The wall switch will respond to button presses as expected.
  3. Turn wall switch to off.
  4. Within Home Assistant, turn on the the light entity.
  5. Attempt to turn off the light at the physical wall switch. The light will not turn off. Attempting to use the physical dimmer will also yield no result.

The device worked properly with manual configuration with Tasmota 6.3, so I know the connections inside the switch are correct. Manually configuring the light causes the same issues. This leads me to believe there is something wrong in my configuration of Tasmota on the device itself.

I am using the Blakadder template for the module, and I haven’t changed any of the SetOptions with the exception of SetOption19 0.

Has anyone ran into a scenario like this?

Did you happen to figure this out? I’m having the same issue.

No, I was never able to figure out what was going on with it. I ended up replacing the dimmers with ones I hadn’t upgraded yet. I have good luck with 6.3

I have the same issue. I haven’t paid it too much attention until recently because most of these switches are automated on/off with IR sensors. However, my wife has recently been complaining about this for guests in the guest room. I’ve noticed if you “take back control” by hitting the dimmer buttons up/down, you can regain the power button. I’ve tried with 9.5 and 13.4. Same issue

1 Like