Matrix ZRB5120 zwave-js incorrect recognized

I have an Logic group Matrix ZRB5120 that used to work, but one day it didnt work. After excude and include it seems to be wrongly recognized.
I did replace with an other brand new one, but same issue.
It is alive, I can ping the device, and i I turn on or of on the device I can se that in HA, but turning on and of in HA dosnt send anything on the zwave network as far as i can se and nothing happens :frowning:

I dont know how to investigate further where te problem could be :frowning: Everything else zwave related i have is working whitout issues.

Any advise or hints or help is apriciated :slight_smile:

How do you notice that it is “wrongly recognized”? Under device info it appears to have the right name, at least.

You can try doing a “Re-Interview” under the “…” menu to reload the configuration options, but exclude/include should have done that anyway.

You can also increase the logging level in the Z-wave add on to see what is happening when you send it commands and what commands it sends.

It seems to be recognized, and have correct name etc. And I can Ping the device, but it dosnt (anymodre) have switches for the to relays it has :frowning:
I have done reinterviev a lot of times, excluded it, included it, excluded it and shifted the wall controler to a nother (same model) and it dosnt work…
Well part of it does work, but not turning on and of the relays…
Trying to read the log dosnt give me any clues as everything seems OK.

Try using the Z-WaveJS UI addon and see if it is properly recognized in there.

:wink: Did that to and same problem. No binary switch entities and nothing speciel in the logs :frowning:

Go into the Developer Tools and Click on the Service tab and type what I typed then click call service and see if that does anything.

Good call, but didnt work :frowning:

I’m not sure what’s going on. The two things I can think of are:

  • In your first screenshot, two switches are visible (Controls (5) and (6)). Do they work?
  • If the devices is recognized and ping-able, but the specific controls don’t work, that suggests that ZwaveJS (the underlying library, regardless of which HA interface you are using) is not associating the right template with the device. Re-interviewing should fix that and the fact that it lists the device correctly suggests that is not the problem.

Control 5 and 6 dis not work. They onle show the state of the relays, and change if I press bottom on the wall controller itself.

Reintervieving dosnt work - neither via HA or JS UI.
I have opened a issue on the zwave-JS-ui github but hasn’t gotten any result yet, but hopefully some clever person can figure out what is the problem :slight_smile:
I can’t :frowning:

I think i created the first configuration for that device, i dont know if it has been updated ever since. Also i dont own the device so its not sure if the device works but it should.
I didnt have any documentation on the device back then so it might be incorrectly set ?

The strange thing is it used to work, bu suddenly it stopped working. I thought the device it self were broken and spent money on bying a new one :slight_smile: So I have to of theese now, but dont know how to make configuration or fix my problem :frowning:

Your best bet would be to download the zwavejsUI standalone version. You download the zip from the GitHub page, then extract it and click on the exe file to get it run. It’s that simple. It also runs on Linux as well. Releases · zwave-js/zwave-js-ui · GitHub. Because of how portable the software is I have multiple versions of older zwavejsUI software that I use for testing. So if it is a software issue you will figure it out by using an older version.

You can try resetting your USB stick. I’ve done this numerous tIimes to test stuff out. Just sure you make a nvm backup before you reset your USB or else you will have to redo your entire network.

Also did you select check RESET SECURITY CLASSES when you reinterviewed your device?

So that error message you received when you tried to use the set value service only occurs if the command class, endpoint, or parameter doesn’t exist on that node. Because the command class id and the parameter are fixed this means your endpoint has to be wrong or that setting just doesn’t exist in the devices firmware. Normally when I see devices with multiple endpoints it’s usually endpoint 0,1 and 2 but yours has 5 and 6. The only thing I can tell you to do is try typing other numbers in the endpoint field starting with 0, 1, and 2. The max number you can input i believe is 255 so just keep typing numbers and work your way up.

Also your device has a bunch of association groups I would try adding the controller to every single one to if that solves the problem.

You can also try using simplicity studio.

Seems like the great gyes at zwave-js found the problem :slight_smile:

Now I just have to figure out how to sponser some money to the project :slight_smile:

1 Like

They just released a new update. Have you tested it yet? I’m curious to see what the problem was and if its fixed.

No not yet. I am running on HAOS and don’t know how to update whiteout waiting for the add on to be updated :frowning:

I would temporarily switch to the Standalone zwavejsUI version. Releases · zwave-js/zwave-js-ui · GitHub

You download the zip and double click on the file to run it. Then connect to the control panel by typing YOURIP:8091. It takes 5 mins max to setup. The only thing you need to copy from your existing setup are your security keys.

If you need to connect it to home assistant you can have multiple zwavejs integrations.

Great - that were easy.

It works as expected :slight_smile:

Looks like they just released the addon update. Did their fix solve your problem?