Matter in Home Assistant workshop announcement

I’m not sure how to do it through chip-tool, but you could try just resetting the board with matter device factoryreset and starting over. One thing to note, I was able to get it into HA over wifi (also don’t have BLE) by first connecting with matter wifi but when calling the commission service, I had to use the ManualPairingCode rather than the QRCode string.

1 Like

I don’t run Proxmox as I installed HAOS direct from the disk image installation page. I can see that the system recognises the adapter via the SSH terminal ub500
I don’t however see it listed in the hardware section of HASSIO so no idea how to proceed with this.

Tried lsusb?

It would be nice to have a second firmware build with a different hard coded pairing such that I can add a second Matter light. Or even better a configurable or esp ID generated pairing key.

1 Like

Yes it shows the device at Bus 001 Device 002 as per this:

I resolved the problem by using the bluetoothctl command via the ssh terminal. I found that the adapter was actually listed and working. So now I have the matter device all up and running :slight_smile:

1 Like

@tboyce1 Can you please post how you got the device into HA over WiFi without BLE? I tried to use ManualPairingCode as you suggested, but I am not having any success or seeing anything in the matter add-on logs.

I’d suggest uninstalling the add-on and the integration, restarting, then install them again to start with a clean slate.

On the device:

matter device factoryreset
matter wifi "SSID" "password"
matter ble adv stop
matter onboardingcodes onnetwork

Leave the console window open on the device because this is where you can tell if it’s working. In HA, call the services matter_experimental.set_wifi (not sure if you really need this since it’s already connected, but I did it anyway) then matter_experimental.commission and put in the ManualPairingCode.

At this point, you should see it trying to commission the device in the console window. Sometimes this just fails and I have no idea why. It will get added to the fabric and set the state to “operational node” but then after some time (30 seconds or so) it gets removed and goes back to “commissionable node”. If that happens, just start over with the factory reset and try again. I just tested this process again and it worked on the second attempt. Good luck!

1 Like

Thanks - I can reliably pair with chip-tool add-on every time. But when I try exact procedure with matter.set_wifi and matter.commission,nothing happens. I just get following in ha error log.

2022-06-21 09:01:36 ERROR (MainThread) [custom_components.matter_experimental.adapter] Failed to inteview node: Command failed: CHIP Error 0x00000032: Timeout

Curiously, “matter onboarding onnetwork” and “matter onboarding ble” print same ManualPairingCode (34970112332) but a slightly different QR Code string (MT:Y.K90AFN00KA0648G00 vs MT:Y.K9042C00KA0648G00 )

I am going to let this sit for a while and come back to it once things become more stable.

The QR string probably encodes the “method” of commission in it whereas the manual pairing code is just the code itself and up to the software to pick the right method.

Just FYI, if it’s already paired to the chip-tool then the process is likely different. In that case, you’d have to figure out how to make chip-tool open the commissioning window for the device since it would no longer be commissionable after being paired. But if it’s not doing anything even right after a factory reset, then yeah, probably just have to wait for things to get ironed out a bit more.

Just curious on this:

Will Home Assistant be able to both control Matter devices and take other devices and bridge them out to a Matter network? My thought is perhaps this renders the HomeKit Bridge integration redundant and we can just bridge out things to it in an “official” way.

Thanks - I was able to get HA to discover the device a couple of times after some factory resets. But it was very non-deterministic process. With chip-tool it is very deterministic process. Such is life with early release software

I’d be interested in this as well. From what I understand, Matter will support bridges for non-Matter devices so I would have to imagine HA could act as a bridge.

What gets really interesting is if it could bridge cloud devices this way as well even though Matter is supposed to be local. I’m sure it’s technically possible, but would it be considered “official”?

In that case, could something like a Nest thermostat only expose itself as a bridge and control the thermostat through the cloud API, thus creating a loophole where the Nest thermostat “supports” Matter but is still only controllable through Google’s servers?

I predict lots of loopholes. I doubt providers are going to rely on quality, features and service to keep you in their ecosystem.

Hopefully, I’m too much of a pessimist.

FYI, Nabu Casa / Home Assistant founders also announced they are making an official Home Assistant SkyConnect USB Stick RF adapter/dongle HW compatible with Matter/CHIP over Thread and Zigbee:

My wish list:

  1. Second firmware build. OR
  2. Ability to change pairing and mac
  3. Config that also exposes buttons
  4. maybe a follow up workshop.

This is a good exercise on integration, whether or not this is final version.

There is a very raw implementation of matter device in nodejs that may be of interest,

I have tried to make it work with HA (with onnetwork setup code), but somehow, HA is unable to complete the process of integrating it into HA after successfully pairing. This issue has some details:

Will Home Assistant act as a Gateway for non-matter devices. e.g. Assume some lights which Home Assistant can control, can be a matter hub (export an interface) so other Matter Apps can see it on the network and control the lights?

In the Blog some one has recommended the “tp-link UB500“ Bluetooth dongle to use.
But it’s unsupported in the integration. See in the link.

During the release party of HA2022.8 they mentioned briefly that they discovered issues with the TP Link Bluetooth sticks. They seem to lose connection and reconnect very often. Maybe this is the reason why they are currently not supported.

1 Like