Matter & Thread: where we’re at

Using an NRF52840 etc instead of the silabs module, or the skyconnect, should be possible right? (After someone does a suitable firmware and integration)

And well done, this is great news and fantastic work!

Is this specific to Apple/Google Thread Border Routers? Or is it designed to work with any Thread Border Router?

My SmartThings Hub v3 also has a built-in Thread Border Router (as does some Nanoleaf stuff, and soon the Echo 4?), so just wanted to make sure

1 Like

I’m trying to update the firmware through the web interface but that does not work at all.
Sky connect is detected but when trying to connect it fails with:

The running firmware could not be detected.

Any ideas?

I updated the SkyConnect to multiprotocoll through HomeAssistant.


The problem was, that i did not install the driver on MacOs.

I am very confused, I believe my HA meets the requirements for these new Matter features, however all I see is the previous capabilities in both the iOS and Android Companion Apps.

Any suggestions please?

are there any chances to get some of my zigbee devices updated to thread/matter?

please find updated docs here:

1 Like

I flashed the SkyConnect with beta EmberZNet v7.2.1.0, stopped Zigbee2mqtt (Zigbee Sonoff USB dongle plus) plugged in SkyConnect, restarted MQTT addon, MQTT integration and lastly Zigbee2mqtt addon. No sweat! Everything works :slightly_smiling_face:
I’m just wondering if enabling multiprotocol support will work???

Good Afternoon Good People

I have added three Matter upgraded Eve Door and Window Sensors into Home Assistant using an Homepod Mini as a TBR.

Everything went well however the binary sensor outputs are all inverted. Works properly in Homekit and the Eve app but in Home Assistant when the door/window is closed displays as open in HA and when its open displays as closed in HA.

Any suggestions please or this an issue for Matter in HA?

1 Like

I am guessing that HA is not ready yet for Thread. With SkyConnect Multi-PAN firmware, I can’t see any of my Thread networks or devices. Even with the nRF52840 board, I could not find, join or make HA joins my hosted network. I am guessing that the Thread device joins the panel feature coming in the next version 2023.3.

the fact that an apple or google devices can be used as thread border router from HA is interesting.
Would love to see similar support for nanoleaf Everything You Need To Know About The Thread Border Router as most of the modern ones include such support as well.

Hi balloob!
“Currently” means that, sometime in the future, this will be available for a non-HAOS version?

A great big up for all the work done in HA. It is really amazing!

Yes, it is stated somewhere else that they will work on core and container installs afterwards.

1 Like

Uhh my estimated shipping date just updated to August 31st. Still no project update in sight. What the hell is going on?? I’d appreciate a realistic update @agners , instead of more meaningless platitudes like “most likely” and “we try hard”…

Is it possible to use the skyconnect dongle on a remote machine and connect to it with ZHA over the network? This is what I do for zwave and zigbee currently because HA OS runs in a vm on a server in my basement.

I can think of one possible way, in theory at least.
On your remote machine where the SkyConnect will reside, use the HA Multiprotocol/multipan software. You can do this either running another instance of HA with the Multiprotocol Add-On or perhaps compile/build it yourself. At your main HA where ZHA resides, instead of configuring ZHA to use a serial/USB device, configure it to use the socket address to connect it to the multiprotocol/multipan software. This socket config will look something like socket://ip_of_remote:9999.

my home assistant runs virtualized on one machine (with no USB support)
it connects to a pi where i run things like frigate, zwave2mqtt (i use integration not mqtt)

I see the skyconnect says it supports zigbee2mqtt (with the experimental firmwatre)
I am a little confused…
If i put skyconnect on the pi, run zigbee2mqtt will i be able to use all the skyconnect thread/mattter/zigbee features?

you seem to know what you are talking about so hope you can takt eh the time to clarify!

1 Like

I’m still coming up to speed on Thread and Matter, but I can speak a little bit to your questions on Zigbee and hopefully help you out a little…

SkyConnect comes from the factory loaded with a ZigBee stack, so zigbee2mqtt can use the SkyConnect directly as any other zigbee usb stick. The protocol used by zigbee2mqtt to talk to the SkyConnect is called EZSP, which is a Silicon Labs protocol that is used to talk to their ZigBee Stack (SkyConnect by the way uses Silicon Labs chipset). zigbee2mqtt has implemented EZSP but they have labeled it as “experimental”, but best I can tell, its been that way for some time and users have been using it just fine.

If one wants to use SkyConnect for both ZigBee and Thread, then Homeassistant provides a solution using their “Multiprotocol” Add-On (which itself is based on Silicon Labs software). This Add-On contains the Zigbee stack (and the Thread stack) and the Add-On can NOT use the original firmware on the SkyConnect. So the Add-On requires the original firmware on SkyConnect to be replaced with something else that the AddOn needs. When you set up the AddOn, there is a selection switch in the config that allows the AddOn to “automatically” replace this firmware. Once this is done, then anything needing the zigbee stack, such as zigbee2mqtt, has to use a socket instead of a serial usb /dev/xxx because the zigbee stack that now resides inside the AddOn requires the application using its Zigbee stack to use a socket. I have had success doing this with zigbee2mqtt, but there are currently some bugs and instability issues, so I would not use zigbee2mqtt with the Multiprotocol Add-On until things settle out.

As for Matter and Thread, the HA solutions to this, which also includes the Multiprotocol Add-On and SkyConnect, are things I’m trying to learn more about, so can’t provide much more insight.

When it comes to splitting things up between HA on a VM, and things running on the PI, I think for sure that you can have an HA instance on the Pi that runs zigbee2mqtt along with the multiprotocol Add-On and use MQTT as the messaging protocol back to your HA instance on the VM. That should work just fine. As for splitting Matter and Thread between your VM and Pi, I’ll have to dig further.


Now with 2023.3 out and several point releases, I turned on the Thread integration and was able to see my nest network. The new panel seems to have some of the functionality described in the mock. Do you know when we will get the synchronization/merge of networks? Or even being able to set the preferred network?

You should be able to set the preferred network now. If you make an attempt to set the preferred network but find that it doesn’t seem to work, then one solution appears in the following thread:

“Matter & Thread: where we are”. No need for the “at”.
Never end a sentence, a preposition with.

Hopefully we start seeing more thread and matter devices shipping.

1 Like