Matter & Thread: where we’re at

As I said, you can’t pair HomeKit over Thread devices to HomeKit and Home Assistant directly at the same time, this is a limitation of the HomeKit protocol.

Thread is just the communication protocol, but the Eve devices run in either HomeKit over Thread or Matter over Thread mode. Only with the Matter firmware you can pair to multiple platforms at the same time.

When I remove a HomeKit over Thread device from my Apple Home. Home Assistant directly finds a new HomeKit device to pair to Home Assistant. This also worked for the Thread devices.

Afterwards you can share the devices from Home Assistant to HomeKit with the HomeKit Bridge function, but keep in mind, for the Eve app the extra entities are gone, so you will have less features than when it is directly paired to HomeKit.


This ismy big gripe with Apple Home. Devices introduced to Home via HomeKit can’t expose their status to other network controllers. Binary devices and some lighting devices are workable around via virtual relay devices but most level devices like say thermostats or pressure values and any textual devices their status value is stuck in Apple Home. Some might be accessible by the HA intermediary path.

I had hoped Home might be able to republish them via Matter… but no.

Thanks again for your help and explanations Daniel, I am getting smarter by the day (as far as possible :slight_smile: ), I will integrate all Thread devices as you described, one by one, into HA so that HA becomes my command center for my home (used to be a combination of AppleHome; EVE and Homebridge). I won’t need any thing special from EVE anymore (I think/hope).
Once again many thanks for your help and patience with me,

Thanks Kevin, it is a shame but that is the way it is for now. Unfortunately the HA Homekit documentation seems to suggest otherwise and tht has cost me quite a bit of time and energy

Actually since Apple added Matter support to Apple Home. The Apple Home app is now a HomeKit and Matter controller, the devices added to Matter are actually not present in HomeKit. For the user it looks the same but in the background they are not the same.

HomeKit is built with the principle that none of the HomeKit accessoires know of each others existence and there is no way for any HomeKit accessory to talk to any other HomeKit accessory directly, this is by design. So there is no way for HomeKit devices to talk to Matter. Eventually accessories won’t be made for HomeKit anymore and they will all just be Matter, but at the moment Matter has more limitations than HomeKit itself in terms of entity types and what type of data can be stored in them.


Hi. Apologies if this isn’t the right place to ask this question but are there any plans to allow Home Assistant’s Matter/Thread integrations to handle OTA firmware updates for Matter devices?
My reason for asking is that I have two Eve Motion sensors - one is connected to a Google Nest TBR/Matter controller and that has already updated the firmware in the sensor. My second sensor is connected using HA’s Matter and OpenTBR integrations and, whilst the sensor works fine, it hasn’t updated the Eve firmware.
I raised a ticket with Eve Support and they replied that currently only Google, Apple and SmartThings support OTA updates. Are there any plans for HA to support this capability?


Also from all my Thread and Matter devices (Eve, Aqara, Nanoleaf, Onvis) only Nanoleaf provides a working app. The others don’t provide an app for Android and I also wasn’t able to make the apps do anything meaningful on iOS.
The Aqara app for Android looks good, but doesn’t yet support their Thread devices (door sensor)

We are seeing Matter being rolled out by Manufacturers (Apple, Google, Philips Hue, EVE etc.) However, the Matter Integration is still in Beta status. Does anyone know when we can expect the operational release?


Did you manage to connect your Nanoleaf products to the thread network of HA?

Does anyone know if and when the Matter Integration will be formally released instead of Beta?

I have one Nanoleaf Essentials E 27 Bulb working well with HA.

I had a lot of trouble when first pairing it… and I can’t recall exactly how I eventually did that.

And it wasn’t working well with Adaptive Lighting at first… I posted on that thread about that issue. But I fixed that eventually and now I’m about to buy lots of Nanoleaf Essentials lights.

1 Like

Nice! I’ve got 30 GU10 lights. So I’m gonna try it I guess

1 Like

Sorry for the late reply.
Yes a bulb and the essential strip.

The Nanoleaf were the easiest to connect and the only Matter device with a working Android app to configure and upgrade Firmware. Onvis, Eve, Aqara don’t offer anything and their iOS apps exist, but are quite crappy and completely unusable.

The only annoying thing about Nanoleaf so far is, if you run a Bluetooth tracker, they fill your device list with hundreds of entries because they advertise themselves with a different ID every few seconds. I had to disable Bluetooth tracking or at least automatic registering of neely found devices., but I only enabled it to experiment anyway. I have no real use.

Ah ok! Yeah there was an update last week for my nanoleaf panels and now everything is on thread. I’ve added my Skyconnect to this thread network and now I can control the led strip via HA. Not the others because they don’t support Matter

I’m a bit unsure where to start, so I’ll try here.
The problem is SkyConnect which stopped working, I tried to find it in HA but to no avail, so far it has been working fine. I’m not specifically writing about any hardware or software configuration here.

My problem is that I cannot upgrade from the website: Home Assistant SkyConnect

I go to this address via Chrome, connect SkyConnect to the USB, press [Update Firmware], a window appears, select the SkyConnect v1.0 device and this is where the uphill journey begins.

I see the progress wheel start spinning - Connecting…, slow down a bit, stop for a moment, showing progress… and start spinning again - Connecting… then I get the message [Page Unresponsive].

It doesn’t look good. Has anyone had this happen? Is there any advice for this?

1 Like

I have too same problem, MacOS 14.2, Apple M2, Chrome …

1 Like

I tried to update the firmware not only using Mac OS, I used two computers with Windows (older and newer) in both cases the same result, progress increased for a moment and then hung indefinitely.

You need to install the cp210 drivers. It should have been written in the instructions somewhere I believe, maybe it got removed.

You can find the drivers here: CP210x USB to UART Bridge VCP Drivers - Silicon Labs

After installing, reinsert and you should see CP210 as a target on the website. That’s what you’ll have to flash.

Any chance that there could either be a new topic created for this, or else have the OP updated? It’s quite a long thread now, and I’m hoping the state of the Matter integration is different now than it was a year ago.

I suspect they will wait until next month, I’m sure they said on a live stream that the matter guys will be at the matter meeting thing, presumably in preparation for the next bi-annual update coming out in Spring.