Matter & Thread: where we’re at

Yesterday I could successfully connect an Eve Power Plug to Home Assistant Yellow via the integrated Thread Boarder Router. Works fine, inclusive power measurement.
I do not have any apple devices.

I may have missed it somewhere in this long discussion, but will the built-in Matter integration be able to flash end devices with new firmware from the manufacturers similar to the Zigbee integration?

The last I heard, No it is not yet supported.

I bought a Home Assistant Green + SkyConnect in the hope to be able to do the same - so far I am not lucky. the Eve Power Plug is shortly seen by my Android 14 phone which tnen offers to set them up for Google Home, but when I try to integrate it just reports “Your device requires a Thread border router”. in the HA Thread Border Router debug log I see no relevant traffic during the connection attempt. what versions of HA and the plugin is your Yellow running?

Anyone know? Matter & Thread - where are we at in May 2024?

I am using Matter & Thread with Nanoleaf bulbs with out any major issues.

only issue is sometimes matter adding device get stuck and restarting the addon fixes it.

I have integrated EVE Devices which are Matter capable and Philips Hue. They all work fine

Ok so I tried changing from Multipan to zigbee and what a fail with the usb stick.

No idea what I am doing. Its probably me but I think we need a good guide to make sure we are doing this right. The silicon labs multiprotocal addon I assume needs to be removed as well?
After changing it to zigbee only the addon kept complaining and none of my zigbee devices were working. Could not afford the downtime so had to flash multipan firmware and re pair 50 odd devices.

Is there a good guide helping us move from multipan to zigbee only or thread only?

Correct, it does

Really, only that is needed is to backup ZHA, remove the multipan add-on, flash with Zigbee only and recreate ZHA from the backup.

@francisp thanks

I forgot to mention I am using Z2MQTT. How do you backup and restore that one?
I am using The Z2MQTT addon so not sure what to update there?

With the add-on, the data is stored in /config/zigbee2MQTT, and zigbee2mqtt should restore when restarting.

This did not work for me previously. Did it the same way. Even added Ember in the config as mentioned in some forums. Gave up restored to an earlier HA backup which set all back to how it was but had to I re-pair all devices. I suspect not as simple based on my experience.

According to [WIP]: EFR32 EZSP adapter implementation and test · Issue #319 · Koenkk/zigbee-herdsman · GitHub , Backup/restore is implemented for ezsp, but I don’t know since when.

Yeah I tried this just day before yesterday. It was a disaster of epic proportions. I think a proper write is necessary. It should have maybe step 1 do this etc

I went to settings > System > Hardware > configure then clicked Remove IEEE 802.15.4 radio multiprotocol - failed
Then I went and stopped the Z2MQTT addon. and did it again - Success
Settings > addons > uninstalled silicon labs multiprotocol addon

Replaced the following with ember in Z2MQTT in addon config

port: tcp://core-silabs-multiprotocol:XXXX
adapter: ezsp

Restarted Z2MQTT addon and nothing worked.

Stop Zigbee2MQTT add-on
First settings → Add-on → Silicon Labs Multiprotocol → Uninstall
Remove your stick and flash it with Zigbee firmware
Put your stick back in
Open Advanced SSH & Web Terminal (add-on) and enter ls /dev/serial/by-id
make note of the value returned by your stick (or better, mark it and copy it to notepad)
Open Zigbee2MQTT add-on settings

port: tcp://core-silabs-multiprotocol:XXXX
adapter: ezsp


port: >
adapter: ember

where you replace xxx with the value found from ls /dev/serial/by-id

Save settings
Start Zigbee2MQTT

Ok where is this exactly?

Also I am on the latest firmware with the online flasher. Do I need to update to 7.4 etc? It did not offer it to me with the online flasher.


Here, in the post above:

For ember you need 7.4.1 or 7.4.3 (I have seen reports that 7.4.2 is buggy)
if using 7.3.x use it so:

port: >
adapter: ezsp

ok got the id and yup on revision":“ build 0”

much appreciated. Now just gotta try it out.

I have ordered the smlight slzb-06 POE stick so eventually use it as the skyconnect usb stick needs to be unplugged - plugged or removed from device manager and added since I am on a X86 Win 11 machine using VirtualBox setup. Every time I boot from scratch I need to do this. Reboots work fine though. Hoping the new device wont have the issue since it POE network based.

Things to figure out. Can the zigbee network be migrated to another stick like the smlight slzb-06?
Does the skyconnect stick perform well with thread alone. Also not sure which network to offload to…which stick

(Dongle E is like the Skyconnect a silabs chipset, Dongle P is like slzb-06 a CC2652)