MaxCube loosing configuration

My Maxcube is loosing the configuration (reset to factory defaults) with and interval of about 3-6 weeks, and I have to setup all devices again. This is really annoying. I have had the MaxCube for about 1 year now, but only connected to HA for about half a year, and it started happening after I connected it to HA. Searching the internet for the issue I found that some OpenHab users experienced similar problems.

Anybody that has this problem in HA? - and better yet have found a solution?

I have tried resetting MaxCube each night by automatically switching off the power for 5 min - in case it was some kind of memory overflow causing this, but this did not help.

I am in the same boat, had to remove the HA configuration.
I think the cube when receives too many poll goes bananas

You may want to try this solution, it may work

I will change the polling interval to 5 min - and see what happens.

How you do this?

It is hardcoded in the maxcube component, so I have changed it directly in the code - the file is
components/maxcube.py
line 72 change 60 to 300
(This is of cause a temporary solution until I know if this will actually help. The change will be overwritten each time HA is updated)

You use hassio?

No I use an odroid xu4 with ubuntu.

I see. I use HASSIO and don’t know how to to change (or even find) the file to change

I too interested to know how to change py files in HASSIO. I use MAX but it looks like it is abandon by hass developers. Few key missing features.

Im going to try and update the file to 10min intervals (HA doesnt need it that accurate). if it works then I’ll try and create a patch for the HA MaxCube component… wish me luck!

Edit
FYI the file to update is https://github.com/home-assistant/home-assistant/blob/dev/homeassistant/components/maxcube.py and its now line 83

1 Like

Thanks, but where to put that file in a HASSIO installation?

Im not using HASSIO (raspberryPI) but using docker. the file is in this location on my image

/usr/src/app/homeassistant/components

one thing to note is there are two maxcube.py files, one in the above location and one in the climate subdirectory. the one to modify is in the components directory

I had a quick look on the haasio page and I think you need to install the SSH AddOn

https://www.home-assistant.io/addons/ssh/

Once installed you should be able to ssh into your haasio filesystem and make modifications

One word of caution… When you update HaasIO, or even my docker image, you need to redo the change. If the changes work then I’ll modify the code and put in a PullRequest allowing us to control the polling from a parameter in configuration.yaml

You can override a build in component with a custom component in the HA configuration folder. This way you don’t have to make your changes each time HA is updated.

I have done that and you can get it here if you want to test it:

  • Create a “custom_components” folder in your HA config folder.
  • Place the maxcube.py file in the folder
  • Add the “update_interval” to you configuration.yaml file

I have been using it now for about 5 weeks, and it has been working fine so far - no resets to factory defaults!

Thanks a lot, will try. under custom_components or under custom_components/climate??

I tried 600 (10 minutes), I think its ok from a user point of view (you do not need to change temperature or read it that often …)

EDIT now I will have to wait until next october to test it though, today we have 30 degrees :slight_smile:

I receive this:
2018-04-30 10:55:55 ERROR (MainThread) [homeassistant.config] Invalid config for [maxcube]: [host] is an invalid option for [maxcube]. Check: maxcube->maxcube->host. (See /config/configuration.yaml, line 437). Please check the docs at https://home-assistant.io/components/maxcube/
2018-04-30 10:55:55 ERROR (MainThread) [homeassistant.setup] Setup failed for maxcube: Invalid config.

I am on 0.68. Shall I use this

maxcube:
  gateways:
    - host: 192.168.1.99
    - update_interval: 600

or this

maxcube:
  host: 192.168.1.99
  update_interval: 600

with first I get

2018-04-30 11:02:02 ERROR (MainThread) [homeassistant.config] Invalid config for [maxcube]: required key not provided @ data[‘maxcube’][‘gateways’][1][‘host’]. Got None. (See /config/configuration.yaml, line 437). Please check the docs at https://home-assistant.io/components/maxcube/
2018-04-30 11:02:02 ERROR (MainThread) [homeassistant.setup] Setup failed for maxcube: Invalid config.

I guess this

maxcube:
  gateways:
    - host: 192.168.1.99
      update_interval: 600

Now no error, but where are the entity_id?

should be sensor.xxxxxx or ?