Home Assistant Community

MaxCube loosing configuration

#14

I had a quick look on the haasio page and I think you need to install the SSH AddOn

https://www.home-assistant.io/addons/ssh/

Once installed you should be able to ssh into your haasio filesystem and make modifications

One word of caution… When you update HaasIO, or even my docker image, you need to redo the change. If the changes work then I’ll modify the code and put in a PullRequest allowing us to control the polling from a parameter in configuration.yaml

#15

You can override a build in component with a custom component in the HA configuration folder. This way you don’t have to make your changes each time HA is updated.

I have done that and you can get it here if you want to test it:

  • Create a “custom_components” folder in your HA config folder.
  • Place the maxcube.py file in the folder
  • Add the “update_interval” to you configuration.yaml file

I have been using it now for about 5 weeks, and it has been working fine so far - no resets to factory defaults!

#16

Thanks a lot, will try. under custom_components or under custom_components/climate??

I tried 600 (10 minutes), I think its ok from a user point of view (you do not need to change temperature or read it that often …)

EDIT now I will have to wait until next october to test it though, today we have 30 degrees :slight_smile:

#17

I receive this:
2018-04-30 10:55:55 ERROR (MainThread) [homeassistant.config] Invalid config for [maxcube]: [host] is an invalid option for [maxcube]. Check: maxcube->maxcube->host. (See /config/configuration.yaml, line 437). Please check the docs at https://home-assistant.io/components/maxcube/
2018-04-30 10:55:55 ERROR (MainThread) [homeassistant.setup] Setup failed for maxcube: Invalid config.

I am on 0.68. Shall I use this

maxcube:
  gateways:
    - host: 192.168.1.99
    - update_interval: 600

or this

maxcube:
  host: 192.168.1.99
  update_interval: 600
#18

with first I get

2018-04-30 11:02:02 ERROR (MainThread) [homeassistant.config] Invalid config for [maxcube]: required key not provided @ data[‘maxcube’][‘gateways’][1][‘host’]. Got None. (See /config/configuration.yaml, line 437). Please check the docs at https://home-assistant.io/components/maxcube/
2018-04-30 11:02:02 ERROR (MainThread) [homeassistant.setup] Setup failed for maxcube: Invalid config.

#19

I guess this

maxcube:
  gateways:
    - host: 192.168.1.99
      update_interval: 600
#20

Now no error, but where are the entity_id?

should be sensor.xxxxxx or ?

#21

If you are on HA 0.68 you get the latest one I made on github. The first one did not work with 0.68 - because 0.68 now support more than one maxcube. (Was release about the same time as i uploaded the first version)

In the next HA version the pull request is merged .so you can get it here if you can’t wait:

(You place it in custom_components, And when you update to next HA version you can remove it)

Note that “update_interval” has been renamed to scan_interval to be more consistent with other components.

#22

thanks, Im trying this out… Also thanks for the hint about “custom components”

Im also using the lightwaverf custom component which isnt part of the standard build, this technique should work there too!

thanks

#23

guys,

Just wanted to update all. I have my interval now set to 10mins on HA and 6Mins on a different project (https://github.com/asantaga/PiHeating) and so far so good no issues…

I dont think HA needs to be kept up to date that often, i might even change HA to be every 15mins. My boiler controller does need to be a little more responsive but every 6mins is fine, and I have a physical/web button which overrides this…

so far so good, no resets…

#24

guys,

Alas i found out today that my settings disappeared on the 31st Mar 2018. it appeared to work fine for 1.5months… :frowning:

I have two systems querying the radiators, one was 10mins seconds and the other one 6mins

I’ll increase HA to 30mins and the boiler control to 15mins… lets see how long that takes… :frowning:

#25

Update for all…

All was working fine, HA polling every 30mins and my Raspberry PI every 15mins and all looked ok. but then oneday I was updating/tweaking HA and after the 10th restart of HA I noticed the MaxCube reset itself again… Im now convinced this is a synchronization issue and we should only have ONE device polling…

For now Ive disabled the HA Polling and are leaving my RaspberryPi Heating controller do the polling every 15mins.

I also found this project by Dimitry (http://www.dmitry-kazakov.de/ada/max_home_automation.htm). Speaking to him via email he has NEVER had an issue… Im investigating to see whats different…

Options now

  • I could go to pure HA, and let HA determine if the boiler needs to be turned on/off (send message via MQTT). The issue here is if you make changes to another part of HA the reboot will cause excessive queries to Max
  • I will extend my PiHeating to provide a REST API which delivers all the data to HA. The benefit here is the PiHeating will only query the cube at most every 15mins (or at reboot) and therefore wont matter if you constatly restart HA…
  • The Max Binding in HA could be modified so that it never queries the valves more than once every 15mins (configurable) , regardless of restarts…

What does everyone else ??

My other approach is to sell up the max stuff and move to Tado…they now have an api which looks nice

#26

I’ve 5 max cubes in different houses. Working fine with the android app. I’ve tryied multiple times to set them on Home Assistant but i’ve always had (with different delay) the Cube reset!
So, also reading these posts, i think that the Max Cube component for Home Assistant should be removed waiting for a strong fix (and some angel working on it).
Now it’s not usable. I’ve found some PHP scripts to read all values from valves (also the valve offset which is not given trought Hassio component).

1 Like
#27

I disagree with removing the component but it can be improved for sure. there are some key values are missing from thermostats. Any developers can pay attention to it?

#28

Reading through all problems with max cube in different smart home solutions, I am almost sure that the basic problem is the connection management in the cube. Using a permanent connection to the cube seems to be the solution. (Setting a higher polling interval just lowers the probability of loosing its configuration.)

The ha maxcube component has at least one another problem: it can’t display temperatures over some value correctly (I don’t remember now, 25.6 °C or something).

#29

Certainly seems to be the case… I can +1 this issue, found my cube reset itself today, which sucks as we are just starting to enter the cold season!

Would be great to find a solution for this that still allows the thermostat targets to be set & viewed in HA.

#30

I think @cs42 is right about the connection issue. I think remmber openhab had the option to keep the connection open. Since April i have had one reset on the Max Cube.
The current library the Max Cube component in HA is using to connect to the Max Cube does not support keeping the connection open. It does not look like @hackercowboy (the author), is maintaining the library anymore, because he has not answered questions for a long time.
I currently don’t have the time to look at this (making a new library and HA component), but I think that is what is needed to solved the reset issue.

1 Like
#31

guys,

I agree the connection mgmt is the issue.

For my project (https://github.com/asantaga/PiHeating), I now poll every 15mins and all is good and I’ve removed the Max! component in HA. Before I had HA Max component AND my PiHeating project running at the same time and Id loose config every couple of weeks…

However I dont have the data in HA, or in InfluxDb/Grafana, which was nice…

I’m currently seeing how this goes, if all goes well (ie no resets) I will expand my PiHeating project so that it exposes the data via a REST call, and/or AutoDiscovery MQTT. I was considering building a HA Max! component for my project but not sure its needed (ie is someone else going to use it?)…

Anyway, waiting to see how this goes before spending more time on it…

Also I DON’T like keeping the connection permanently open as this means you wont be able to use the Native Max! apps… The wife likes the ability to raise/lower temperatures using the nice max apps, the only issue is the boiler controller wont see the change for up to 15/20mins… I have a “check heat” button on the app which she can press immediately but its not usually an issue (yet)

1 Like
#32

Max Cube folks - you might be interested in Homematic and Eq3 Max! Cube

I managed to get everything up and going this weekend and it seems to work nicely.
I’ll be posting a bit of a setup guide when I get time, but the big plus is there should be no more issues with forgotten cube config!

1 Like
#33

Hi, do any of you using max cube on Hassio and it wokrking fine?
I am trying now for several months but problem is that after a while cube lose configuration.